Echoing in Jitsi Conference

Hi,

I am facing echo voice in JITSI Conference, while using speaker in laptop / mobile! Please help.

Any reason why you are not using a headset?

The browsers do the echo cancellation, and while it’s generally quite good it’s not perfect. A headset is the best solution.

Otherwise, check that you have not turned off echo cancellation (e.g. by enabling stereo / high quality audio), and make sure you’re not using any app/plugin which would delay/modify the audio from the microphone on your device.

Also, echo/feedback would be expected if you join twice on the same device or join two devices near each other, in case you’re doing that during testing and getting echo.