Easy way to create a Jitsi cluster

Hello @emrah, I downloaded the files of installer again, exported the domains, but I’m getting these errors:

-------------------------- eb-buster --------------------------
Already installed. Skipped…

Please set REINSTALL_BUSTER_IF_EXISTS in eb-jitsi.conf
if you want to reinstall this container

---------------------- eb-buster UPDATE -----------------------
lxc-start: eb-buster: lxccontainer.c: wait_on_daemonized_start: 842 Received container state “ABORTING” instead of “RUNNING”
lxc-start: eb-buster: tools/lxc_start.c: main: 330 The container failed to start
lxc-start: eb-buster: tools/lxc_start.c: main: 333 To get more details, run the container in foreground mode
lxc-start: eb-buster: tools/lxc_start.c: main: 336 Additional information can be obtained by setting the --logfile and --logpriority options

Something went wrong. The installation couldn’t be completed!

And the jibri containers is showing the same errors when I try to start them.

Could you try the following?

stop the template

lxc-stop -n eb-buster

destroy it

lxc-destroy -n eb-buster
rm -rf /var/lib/lxc/eb-buster

restart the installer. The installer will create the template if it’s not exist. The template seems corrupted too. If someone didn’t delete something from the container’s file system you may have a disk issue.

1 Like

Wow! Thanks for the quick response!

I did and works, finally!

But even before did it, when Jibri is still working, I had realized that it was splitting the records…

Is there some configuration that do that? Or it is some performance issue? It is not a big problem, but if I could fix it, will be better.

Two another questions:

  • I had enabled colibri, as you said, but where am I supposed to open the file downloaded by curl?
  • If the 11 jibri containers running on my machine turn out to be a performance issue, and I decide to use Jibri nodes on differents VM, I need only to run add_jibri_node and stop the containers in this machine?

Thanks very much again and sorry for any inconvenience.

I saw a config related in this issue but I’m not remembering where… But I updated the jibri finalize script a few days ago. Now, it can manage multiple MP4 files.

The colibri port (TCP/8080) is only accessable inside the server or the containers.

curl http://172.22.22.14:8080/colibri/stats

If you want to access it from the outside, you need to add a NAT rule to nftables. Check /etc/nftables.conf.

To disable the jibri instances for this server, you need to do followings

systemctl stop jibri-ephemeral-container.service
systemctl disable jibri-ephemeral-container.service

But there is another alternative, you can limit the instance number. Update LIMIT in /usr/local/sbin/jibri-ephemeral-start and restart the jibri-ephemeral-container service. For example

/usr/local/sbin/jibri-ephemeral-start

LIMIT=8
systemctl restart jibri-ephemeral-container.service

Add the JMS key to the new jibri machine as described in the doc and run the add_jibri_node command on JMS

Nice! I saw that the finalize_recording.sh was changed, but I changed it again to what you suggest in a post before, to move the files out of the random folders. How can I merge this functions?

I see… but the colibri stats is a webpage? Because i don’t have a desktop environment in this server, so the only thing I did in these files was a cat. If so, I will do the NAT to follow the conferences.

#!/bin/bash
set -e

[[ "$(whoami)" != "jibri" ]] && exit 1

DEST="/usr/local/eb/recordings"
FOLDER=$1
KEY=$(basename $FOLDER)

for VIDEO_PATH in $(find $FOLDER -name '*.mp4')
do
    VIDEO_NAME=$(basename $VIDEO_PATH)
    VIDEO_NAME_KEY=$(echo $VIDEO_NAME | sed "s/.mp4/_$KEY.mp4/")

    mv $VIDEO_PATH $DEST/$VIDEO_NAME_KEY
done

rm -rf $FOLDER

exit 0

It’s a JSON output, not designed for UI… So, no need the desktop environment.

1 Like