Easier Meeting Names for Apps

I wanted to ask if the public Jitsi server could add the syntax rules for their meeting names, so that all rooms are not allows to have the following characters: “.”, “:”, and “/”.
The reason I ask this, is so that those of us that want to use Jitsi privately can have an easier time getting users on their Jitsi server, as opposed to the public one.
I wanted to ask where I can contribute on Github for the iOS and Android apps for Jitsi? I would like to have both apps assume that once one of those characters are introduced above, it is using a private Jitsi server. When a user enters “example.com/meeting1234”, it will go to http://example.com/meeting1234 on the server on example.com.
Another thing that would be really, really nice is to allow the Jitsi mobile app client to be redirected from http to https, for the users that drop the “s”.

example.com/meeting1234 -> http://example.com/meeting1234 (if https redirect) -> https://example.com/meeting1234
http://example.com/meeting1234 (if https redirect) -> https://example.com/meeting1234
example.com -> http://example.com/ (if https redirect) -> https://example.com/
example.com/ -> http://example.com/ (if https redirect) -> https://example.com/
http://example.com/ (if https redirect) -> https://example.com/

also, please, keep in mind, there are TLD’s outside of .com, .net, .org, and .gov. There is .space, .io, .us, .ca, .uk, many many many!!! I think we should just look for a “.”, then see if we can turn that into a proper URL, then see if the domain is legit.

Hi, was this the wrong forum thread?

probably not but … after reading 2 times your first post I have to admit I am still bewildered by your post and I don’t understand at all what you want. Note that there are not many people wanting to reply to posts willing to read them 2 times to try to understand what is the matter exactly.

@gpatel-fr, thanks for the reply!
Alright, When I typed in “example.com/test1234”, it brings it doesn’t bring me to my private Jitsi server, it brings me to Jitsi’s public server.

I will try to say it with other words – as far as I understand…

The Jitsi Meet App leads you always to the Jitsi default server. Is it meet.jit.si? I am not sure because I never used it.

Whenever you want to use a specific server (and not the default server), you need to go into the App’s settings, enter that server’s name into the line “server URL”, close the settings and then enter the room name. This is very complicated – especially for inexperienced users who possibly even don’t know what a “Jitsi Meet server” is.

Furthermore, when you want to enter another room which is located on a different server, you have to go through this whole settings procedure again.

It would be much easier if the user could enter the server name together with the room name: not in the settings but simply in the input field for the room. For example:


The server name you enter in the room name field should then supersede the server name from the settings.
All in all, I think Eliter’s idea is very good and worth implementing.

[And sorry if I have mixed up some words, I am not an English native.]

All right, with @Marqqs explanation the light has come.

It’s a valid concern, but the fact that it’s not easy to switch server through the settings don’t make an UI where the user would have to enter the server name along the room name more friendlier. The only thing that such an approach would have could be to mimic the effect of sending a link with mail, otherwise it would be a pain.

If there is the need to manage several servers (say the Jitsi one and a couple of privately hosted servers) I’d prefer to have either

  • several shortcuts on the phone screen
  • or a multivalued field in the settings with a separate field on the main screen to select the server (but it would be limited thanks to the small size)

about the invite link sent by mail, my knowledge of Android apps is way too limited to think of a way to solve it. The problem comes from the fact that an app is not a browser and the field selecting the room is not an URL (it’s not either in the Web UI)

replying to myself :slight_smile: the problem is worked on