Each participant in one meeting

Hello everyone.

I make this post because i’m new to jitsi and I was thinking i’m mad.
The thing is that I try to host a jitsy instance.

I followed this website to do it on ubuntu server https://www.digitalocean.com/community/tutorials/how-to-install-jitsi-meet-on-ubuntu-20-04

It works but …

With the same url, each participant doesn’t see each other, and so cannot communicate (video, text, audio). 443 and 10000 ports are done.

I thought i was crazy but watching many posts on this forum … relate the same issue.

So I was wondering if this issue was solved ? I do not encounter this problem with the online (jitsy) version.

.: more issue : instance doesn’t ask for password (even if configured for that). Let’s encrypt issue too.

Thank you for you help.

edit : i can give you rurl in private if necessary

Welcome to the forum!

It sounds like a few things could be wrong with your installation. Check to make sure a firewall is not blocking your ports. Make sure those ports (80/tcp, 443/tcp and 10000/udp) are open and forwarded appropriately. Make sure 10000/UDP in particular is appropriately forwarded because it’s the most implicated in the problem you’ve described. If you’ve done all these and the problem still persists, then check the Advanced section of the Quick Install Guide -Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook

Hello @Freddie thank you for your answer.
Actually I forgot the 80 port, but it was the occasion to check all ports.
But it doesn’t change anything.
Even the text I write doesn’t appear in chat history. And 2nd browser doesn’t see history list of conference.
I’ve done a new install again, changing the dns name to do fresh install.
Check ports. I tried to modify parameters written on the website you gave me (change ip, …)

Still same issue :confused:

Okay, just to be clear, there are two places to make sure ports are open:

  1. On your server (if you’re using a firewall)
  2. On your router (if you’re behind a NAT)

Have you opened the ports in both places?

router : actually it’s the image I uploaded
server : the tutorial advice to do :

  • sudo ufw allow 80/tcp
  • sudo ufw allow 443/tcp
  • sudo ufw allow 4443/tcp
  • sudo ufw allow 10000/udp

I created thoses rules but actually ubuntu firewall is inactive

image

What’s the Letsencrypt issue you’re having? That needs to be resolved 'cos JItsi works over https

I do not use let’s encrypt, even if I connect to https interface.
I didn’t resolved let’sencrypt issue because when I launch the script, it tells me :

certbot no such file or directory

And it’s right, there is not such file or directory.

Well, that problem needs to be fixed before moving on to other things. Are you or the other participants connecting on mobile?

I tried with other browser and tried with mobile too

Do the participants all land in the same room but just can’t see each other or do they all end up alone in different rooms?

Ok so i resolve the letsencrypt problem
image

They are all alone. If one write something, the other can’t see.
Jitsi say to each participant that he is alone in the meeting (message at the top)


(alone)

And if i write something here, I validate with enter, the text disapear.

Right - so they’re not actually connected then. Each person is just seeing a video of themselves, there’s no real instance of a meeting.

This is a trivial question, but just in case: did you restart all services - jitsi, jocofo, videobridge? If so, share your logs, perhaps there’s something in there that could clue us in.

I restarted services and machine.

jvb.log

Preformatted textError: A fatal exception has occurred. Program will exit.
Unrecognized VM option ‘UseConcMarkSweepGC’
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
Unrecognized VM option ‘UseConcMarkSweepGC’
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
Unrecognized VM option ‘UseConcMarkSweepGC’
(this message repeat many times)

jicofo.log
Jicofo 2021-01-14 18:55:52.378 INFO: [1] org.jitsi.jicofo.xmpp.IqHandler.log() R egistering IQ handlers with XmppConnection.
Jicofo 2021-01-14 18:55:52.383 INFO: [1] org.jitsi.xmpp.component.ComponentBase. log() Component org.jitsi.jicofo. config:
Jicofo 2021-01-14 18:55:52.384 INFO: [1] org.jitsi.xmpp.component.ComponentBase. log() ping interval: 10000 ms
Jicofo 2021-01-14 18:55:52.384 INFO: [1] org.jitsi.xmpp.component.ComponentBase. log() ping timeout: 5000 ms
Jicofo 2021-01-14 18:55:52.384 INFO: [1] org.jitsi.xmpp.component.ComponentBase. log() ping threshold: 3
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.dom4j.io.SAXContentHandler (file:/usr/ share/jicofo/lib/dom4j-1.6.1.jar) to method com.sun.org.apache.xerces.internal.p arsers.AbstractSAXParser$LocatorProxy.getEncoding()
WARNING: Please consider reporting this to the maintainers of org.dom4j.io.SAXCo ntentHandler
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflect ive access operations
WARNING: All illegal access operations will be denied in a future release

prosody.log
Jan 14 19:20:00 bosh6779c393-68d1-41fa-9afa-0a823be05c72 info BOSH client disconnected: session close
Jan 14 19:20:01 mod_bosh info New BOSH session, assigned it sid ‘6193ca65-2c7c-45cc-bf72-dc37c1b5f477’
Jan 14 19:20:12 bosh7f7d7c50-5d68-4f62-a70a-82913e2ab2b8 info BOSH client disconnected: session close
Jan 14 19:20:38 bosh021eb9a3-5e94-487c-9cf0-f61ac6b40a98 info BOSH client disconnected: session close
Jan 14 19:32:52 mod_bosh info New BOSH session, assigned it sid ‘6c9792ce-23ee-461a-829c-4728113404ec’
Jan 14 19:33:21 mod_bosh info New BOSH session, assigned it sid ‘c8a696d4-5589-420f-a741-ec2245c4f56d’
Jan 14 19:33:31 bosh6c9792ce-23ee-461a-829c-4728113404ec info BOSH client disconnected: session close
Jan 14 19:57:40 mod_bosh info New BOSH session, assigned it sid ‘8b4efd27-1a1c-4f14-8fac-708632e7488b’
Jan 14 19:58:04 mod_bosh info New BOSH session, assigned it sid ‘c579344d-9bf7-484f-a105-cd56646f69c7’
Jan 14 20:00:26 mod_bosh info New BOSH session, assigned it sid ‘16927072-51e3-4caf-8340-364354f73602’

nginx

2021/01/14 20:36:41 [error] 10613#10613: *200 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.26, server: jitsi.nopublicdomain.com, request: “POST /http-bind?room=testroom HTTP/1.1”, upstream: “http://127.0.0.1:5280/http-bind?room=testroom”, host: “jitsi.nopublicdomain.com”, referrer: “https://jitsi.nopublicdomain.com/testroom
2021/01/14 20:40:53 [error] 10614#10614: *356 open() “/usr/share/jitsi-meet/static/head.html” failed (2: No such file or directory), client: 192.168.1.1, server: jitsi.nopublicdomain.com, request: “GET /static/offline.html HTTP/1.1”, subrequest: “/static/head.html”, host: “jitsi.nopublicdomain.com”, referrer: “https://jitsi.nopublicdomain.com/pwa-worker.js
2021/01/14 20:40:53 [error] 10614#10614: *356 open() “/usr/share/jitsi-meet/static/base.html” failed (2: No such file or directory), client: 192.168.1.1, server: jitsi.nopublicdomain.com, request: “GET /static/offline.html HTTP/1.1”, subrequest: “/static/base.html”, host: “jitsi.nopublicdomain.com”, referrer: “https://jitsi.nopublicdomain.com/pwa-worker.js
2021/01/14 20:40:53 [error] 10614#10614: *356 open() “/usr/share/jitsi-meet/static/title.html” failed (2: No such file or directory), client: 192.168.1.1, server: jitsi.nopublicdomain.com, request: “GET /static/offline.html HTTP/1.1”, subrequest: “/static/title.html”, host: “jitsi.nopublicdomain.com”, referrer: “https://jitsi.nopublicdomain.com/pwa-worker.js
2021/01/14 20:41:41 [error] 10613#10613: *200 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.26, server: jitsi.nopublicdomain.com, request: “POST /http-bind?room=testroom HTTP/1.1”, upstream: “http://127.0.0.1:5280/http-bind?room=testroom”, host: “jitsi.nopublicdomain.com”, referrer: “https://jitsi.nopublicdomain.com/testroom
hidemydomainhidemydomainhttp-bind?room=testroom", host: “jitsi.nopublicdomain.com”, referrer: “https://jitsi.nopublicdomain.com/testroom
ver: jitsi.nopublicdomain.com, request: “POST /http-bind?room=testroom HTTP/1.1”, upstream: “http://127.0.0.1:5280/http-bind?room=testroom”, host: “jitsi.nopublicdomain.com”, referrer: “https://jitsi.nopublicdomain.com/testroom
hidemydomainhidemydomainhttp-bind?room=testroom", host: "jitsver: jitsi.nopublicdomain.com, request: “POST /http-bind?room=testroom HTTP/1.1”, upstream: “http://127.0.0.1:5280/http-bind?room=testroom”, host: “jitsi.nopublicdomain.com”, referrer: “https://jitsi.nopublicdomain.com/testroom

strangly i do not see the public ip of my phone, but my gateway 192.168.1.1; for security i replace my domain name with nopublicdomain.com

So, as you can see, you don’t have a functioning bridge, Jicofo is unhappy, Prosody is wondering what da heck is going on and Nginx is going crazy. This is a botched install, buddy; I recommend starting over. I haven’t looked at the guide you followed but digitalocean is pretty reputable, so I’d say follow the instructions very carefully. You’re working in a VM, which could create another level of challenges if care is not taken. And yes, you’re not seeing the public IP of your phone 'cos like I mentioned earlier, there’s really no meeting being created, no connection being made. Save yourself the headache and just start over.

I start over 4 times (really :rofl:) that’s why I went here.
So I decided to follow the official tutorial, without local authentication.

New tutorial: Installing Jitsi Meet on your own Linux Server - Jitsi

And it works, when I write text, I can see it. But … when the 2nd participant arrive => disconnected, a problem occured.

Like this post

https://community.jitsi.org/t/meeting-error-unfortunately-something-went-wrong/83751

jvb says " fatal error exception, unrecognized vm option useconcmarksweepgc"
jicofo seems ok (just grant owner to the las participant)
prosody show the deconnection too.

I browsed the forum, and someone solved this with unstable version.
So I started (again and again) fresh install with unstable aptlist. But I get more message error : 404 Not Found, Connection error, Your device may be offline or our servers may be experiencing problems.