Hi there.
I have a self docker instalation and in my .env i have a json link to variable DYNAMIC_BRANDING_URL.
It was working until friday(may have to do with today new jitsi meet version? ).
Now, my logo has a link to jitsi.org.

What did change?

my json is like
“inviteDomain”: “”,
“backgroundColor”: “#F82F4A”,
“backgroundImageUrl”: “”,
“logoClickUrl”: “”,
“logoImageUrl”: “https://…svg”

thank you very much


try to set it to google.com and check whether it is re-directing to google or not if yes then you can use your own url.

I tried this already. It doesn’t work.

Was working till friday, now it seems it ignores the dynamic branding url link

I have to edit the interface config
interfaceConfig.JITSI_WATERMARK_LINK = ‘’;

but it is not the best solution.

Not sure if I am comprehending the code correctly, but it does seem strange that _logoLink gets overidden with JITSI_WATERMARK_LINK whenever dynamic branding data is provided on non vpaas meeting:

@Antonio_Pereira assuming your deployment can support room names with tenants prefix, can you test if your url link works if you create a meeting like https://meet.yourdomain.com/vpaas-magic-cookie-0000/anyRoomName? The vpaas-magic-cookie- prefix in the tenant path is important.

Oh… I missed the defaultBranding flag. Would work correctly if defaultBranding=false. My bad.

I already looked to this code, my room name is just “room55”.

i tried with defaultBranding flag too


"inviteDomain": "",

"backgroundColor": "#F82F4A",

"backgroundImageUrl": "",

"logoClickUrl": "url_to_my_page",

"logoImageUrl": "url_to_svg",

"useDynamicBrandingData" : true,

"defaultBranding" : false


But i’ll try that and i’ll answer.

1 Like



i have the json url.
the json file is like this:

“inviteDomain”: “”,
“backgroundColor”: “#F82F4A”,
“backgroundImageUrl”: “”,
“logoClickUrl”: “link_to_url”,
“logoImageUrl”: “link_to_image”,
“useDynamicBrandingData”: true,
“defaultBranding”: false

but in


i have this

  1. avatarBackgrounds:
  2. backgroundColor: “”
  3. backgroundImageUrl: “”
  4. customizationFailed: false
  5. customizationReady: true
  6. defaultBranding: true
  7. didPageUrl: “”
  8. inviteDomain: “”
  9. logoClickUrl: “”
  10. logoImageUrl: “”
  11. premeetingBackground: “”
  12. useDynamicBrandingData: false
  13. virtualBackgrounds:

i don’t know if has to do with this function

export function getDynamicBrandingUrl(state: Object) {
const { dynamicBrandingUrl } = state[‘features/base/config’];

if (dynamicBrandingUrl) {
    return dynamicBrandingUrl;

const baseUrl = state['features/base/config'].brandingDataUrl;
const fqn = extractFqnFromPath();

if (baseUrl && fqn) {
    return `${baseUrl}?conferenceFqn=${encodeURIComponent(fqn)}`;


Possibly. There was a recent fix to load dynamic branding Url from configs directly and not from store since it might not be available soon enough.

1 Like

Thank you very much :slight_smile:

I don’t get it. Is this still broken in current Docker stable release?

Using the unstable docker images from today it works. Although I can only say that for the logo, not the background.

I’m currently on the 6433 custom deployed Docker Version and I could not get it to work. My url branding is read from .env correctly (since exploring web docker container shows that config.dynamicBrandingUrl has the right value), but there are 0 changes on my embedded iframe. The only way I found to customize my elements is to mount custom-interface_config.js file.

In the custom-interface_config.js file I just put this lines:

interfaceConfig.APP_NAME = 'XYZ Meeting'
interfaceConfig.NATIVE_APP_NAME = 'XYZ Meeting'
interfaceConfig.DEFAULT_BACKGROUND = "#405DA9"
interfaceConfig.JITSI_WATERMARK_LINK = "https://www.XYZ.com/"
interfaceConfig.LIVE_STREAMING_HELP_LINK = "https://www.XYZ.com/about"
interfaceConfig.PROVIDER_NAME = "XYZ"
interfaceConfig.SUPPORT_URL = "https://www.XYZ.com/"

If you want to disable any watermarks, you can put:

// Removing watermark (but not showing yours for some reason)
interfaceConfig.SHOW_JITSI_WATERMARK = false
interfaceConfig.SHOW_BRAND_WATERMARK = true

Then in the docker-compose.yml file: