Duration time not showing

Did you fix the storage config in prosody?

Hi,

In /etc/prosody/conf.avail/meet.domain.com.cfg.lua I have:
storage = “memory”
If I change to “none” I can’t obtain the ID session in authentication

In welcome page, after finish the meeting the duration it’s correct. Only in conference not appear the timer on top.

Do you have this in your config: https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet-prosody/prosody.cfg.lua-jvb.example#L41

Yes, I just checked.
The timer worked bu after the changes bellow no more work:

`nano /etc/prosody/conf.avail/jitsi.example.com.cfg.lua`

Change the "authentication" option from "anonymous" to "internal_plain":

`authentication = "internal_plain"`

Open the Jifoco configuration file:

`nano /etc/jitsi/jicofo/sip-communicator.properties`

Add this option to the bottom of the file:

`org.jitsi.jicofo.auth.URL=XMPP:jitsi.example.com`

To create a user in Prosody, run this command:

`prosodyctl register yourusernamehere jitsi.example.com P@ssw0rd`

Restart the Prosody and Jitsi services to apply changes:

`nano /etc/prosody/conf.avail/jitsi.example.com.cfg.lua`

Add a new VirtualHost section to the bottom of the file:
`VirtualHost "guest.jitsi.example.com"    authentication = "anonymous"    c2s_require_encryption = false`

Open the Jitsi Meet configuration file:
`nano /etc/jitsi/meet/jitsi.example.com-config.js`
Uncomment and set the "anonymousdomain" option:
`anonymousdomain: 'guest.jitsi.example.com',`

Any ideas?

Hello all,
I asked the same question, I have also the latest prodosy version
srv@meet:~$ dpkg -s prosody | grep Version
Version: 0.11.5-1~bionic6
I’m waiting your appreciated help, thanks!

since it is the same topic, I join this discussion here:

You can see the time duration as “0:00” but it never start?
That is my problem and I’m using the latest stable prosody version.

In my case I can’t see “0:00”, it’s like disabled.

I think I found the issue, but I didn’t find the solution.
I made a lot of investigation, I reinstall new jisti instance and enable secure domain.
I remarked when I add guest profile into /etc/jitsi/meet/jitsi.example.com-config.js, the clock (conference duration ) is disappeared!?
this line that I add: “anonymousdomain: ‘guest.jisti.example.com’,”
and when I comment it , the clock is appeared, it’s strange I don’t know why?
I hope some expert can help us to solve it.

Great Yassine!
Now waiting some expert to help us solve this.
Thanks

@Yassine nice catch! Can you do the following: enable anonymousdomain, so it does not work, enter a conference as guest so you don’t see it … or do you see it if you enter authenticated?
And once you repro open javascript browser console and execute APP.conference.saveLogs(), send me the file to damencho at jitsi dot org, so I can check it.

Thanks a lot Damenchon for your reaction!
the file has sent successfully to you.
to answer your questions:
for both user profile guest or authenticated, I can’t see conference duration.
your help is appreciated!

Can you try adding modules enabled and conference_duration module under the guest domain, restart prosody and try again?

I add it like below, but it seems doesn’t work.

VirtualHost “guest.meeting.mydomain.duckdns.org
authentication = “anonymous”
modules_enabled = {
“conference_duration”;
}
c2s_require_encryption = false

I add it like below, but it seems doesn’t work.

Neither to me @damencho

@damencho
Hello Damencho,
there is any solution to our problem?

Thank you!

I’m not sure why it is not working when you add it to the guest virtualhost, should be fine looking at the files you send me. There is a disco info query that was done against the guest virtualhost and was not returning the duration capability …
O wait you need a small modification:

VirtualHost “guest.meeting.mydomain.duckdns.org”
authentication = “anonymous”
modules_enabled = {
“conference_duration”;
}
conference_duration_component = "conferenceduration.meeting.mydomain.duckdns.org"
c2s_require_encryption = false

Can you try it, does it change anything?

1 Like

now, the only authenticated user can see the clock, it’s not appeared for the guest.

Thank you!

@Yassine @damencho
Confirmed. Only the host can see the timer. Guest users not able to see.
It’s almost done…
Thanks

Hello @damencho, there was a progress from your suggestion, I think we are near from the solution. we still need your hands to solve it.
Thanks!