Don't ask for mic-permission in startWithAudioMuted

Hi
I’m trying to adapt jitsi-meet for my use case in which I would like to have users in listen-only mode. I would like that they don’t have to give their mic-permission if they only want to listen in a conference

It seems that this was the functionality before release 3758:
https://github.com/jitsi/jitsi-meet/commit/c494d6c48b89a2a9937a369117119b8dfbfbe9d1?diff=split#diff-f1dfd122026e13422664665b42231196

so I tried to adapt conference.js in the following way:

    const initialDevices = [ ];
    let requestedAudio = false;
    let requestedVideo = false;

        if (!options.startWithAudioMuted) {
        initialDevices.push('audio');
        requestedAudio = true;
        }

The functionality seems to work: The users only gets the “Ask-for-permission” prompt if he wants to unmute the mic.
But there is the problem that when a user joins the conference muted, he can not hear any audio. He has to unmute his mic, give the mic permissions and rejoining the conference for being able to hear the others talking.
Does anyone has an idea why this is the case?

Jitsi-version: latest stable
Browser for testing: latest chrome (81.0.4044.129)

Any help would be appreciated!
Thanks!

3 Likes

There was an Agreement between @emcho and @andrei-gavrilescu (https://github.com/jitsi/jitsi-meet/pull/4705#discussion_r344134249) about this.
I think we can achive that with a new config options maybe (https://github.com/jitsi/jitsi-meet/pull/6638/files)

1 Like

Hi, I’m trying to implement the same in the native part, but I can’t find where the audio permission request is triggered when I’m joining with startWithAudioMuted=true on iPhone. Can somebody help me with this?
Thanks in advance

Any update on this from anyone? Would love to get this to work.

I think such a prompt the first time you join the website really scares the user and I’d like to have an iframe on my my landing page https://chagai.website

If I understand correctly there should be a config to go in without hearing audio and then there would be no need to accept permissions just yet?

I assumed it was startSilent, except I just tested it and it still asks for permissions :frowning:

1 Like

Are you skipping the pre-join?

I just tried both and it’s asking for permissions in both cases… you mean config.prejoinPageEnabled=true right?

Try disableInitialGUM: true in config file

2 Likes

Prejoin disabled, to skip it?

It’s not working either way…

This is interesting, I think this did the trick, thanks!

1 Like