Does not work if change the jitsi-videobridge domain

Hi, I got the error there is no videobridge available when I changed jvb domain from old (jitsi-videobridge) one to new one (jvb) in the /jitsi-meet/config.js file:

var config = {
    hosts: {
        domain: 'jitsi.example.com',
        muc: 'conference.jitsi.example.com',
        bridge: 'jvb.jitsi.example.com',
        focus: 'focus.jitsi.example.com'
    },
    useNicks: false,
    bosh: '//jitsi.example.com/http-bind', // FIXME: use xep-0156 for that
    //chromeExtensionId: 'diibjkoicjeejcmhdnailmkgecihlobk', // Id of desktop streamer Chrome extension
    //minChromeExtVersion: '0.1' // Required version of Chrome extension
};

Of course, I already registered an account jvb in prosody and change its component as below:

Component "jvb.jitsi.example.com"
        component_secret = "BmzF20s!"

How to solve this problem?

The bridge no longer uses component. You need to configure it to use mucs: jitsi-videobridge/muc.md at master · jitsi/jitsi-videobridge · GitHub

@damencho that document seems was out of date, right? Because I did not see sip-communicator.properties file on the master branch.

??? What do you expect to see in master?

Here is the default configuration when using quick install:

Thanks a lot @damencho. Here is what I did the configuration

  1. I created a sip-communicator.properties under jicofo project
org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.example.net

and then I set a fews of arguments for running command line

--host=localhost
--domain=jitsi.example.com
--secret==mz2020!
--user_domain=auth.jitsi.example.com
--user_name=focus
--user_password=mz2020!
-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=~/workspace/projects/jitsi/jicofo
-Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi
-Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties
  1. I created a sip-communicator.properties under jitsi-videobridge project and configured as below:
# Enable broadcasting stats/presence in a MUC
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc

# Connect to the first XMPP server
org.jitsi.videobridge.xmpp.user.xmppserver1.HOSTNAME=jitsi.example.com
org.jitsi.videobridge.xmpp.user.xmppserver1.DOMAIN=auth.jitsi.example.com
org.jitsi.videobridge.xmpp.user.xmppserver1.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.xmppserver1.PASSWORD=mz2020!
org.jitsi.videobridge.xmpp.user.xmppserver1.MUC_JIDS=JvbBrewery@internal.auth.jitsi.example.com
org.jitsi.videobridge.xmpp.user.xmppserver1.MUC=JvbBrewery@internal.auth.boris2.jitsi.net
org.jitsi.videobridge.xmpp.user.xmppserver1.MUC_NICKNAME=unique-instance-id
#org.jitsi.videobridge.xmpp.user.xmppserver1.DISABLE_CERTIFICATE_VERIFICATION=true

VM options:

-Dorg.jitsi.videobridge.ENABLE_STATISTICS=true
-Dorg.jitsi.videobridge.DISABLE_TCP_HARVESTER=true
-Dorg.jitsi.videobridge.STATISTICS_INTERVAL=5000
-Dorg.jitsi.videobridge.STATISTICS_TRANSPORT=muc,colibri
-Dorg.jitsi.videobridge.rest.private.jetty.host=0.0.0.0
-Djava.util.logging.config.file=~workspace/projects/jitsi/jitsi-videobridge/jvb/lib/logging.properties
-Dnet.java.sip.communicator.SC_HOME_DIR_NAME=~/workspace/projects/jitsi/jitsi-videobridge/

Running command line arguments

--apis=rest,xmpp
--host=localhost
--domain=jitsi.example.com
--port=5347
--secret=mz2020!

However, it does not work. The error I am facing is CONFERENCE FAILED: VideoBridge Not Available. What’s wrong in the configuration?

I don’t know :slight_smile: what does jvb logs say?