Docker jitsi-meet setup on CentOS 8

Hello,

I’ve been attempting to resolve this issue on my own to no avail. I’m attempting to setup jitsi-meet via docker on a new CentOS 8 server with no other services beside the basic server configuration. I am quite new to server setup, as well as docker and would appreciate any help on the matter.

I installed jitsi-meet following the guide at https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-docker . I believe to have all requisite ports open, but there is likely an issue with the prosidy setup, which I cannot identify. When joining a meeting in jitsi I get the following errors and accessing http-bind at the meet.example.com:8443/http-bind throws an 504 error:

This is the error shown on the web docker logs:

2020/11/20 09:25:50 [error] 261#261: *31 connect() failed 
(113: No route to host) while connecting to upstream, client: 
[IP address], server: _, request: "POST /http-bind?room=test1 HTTP/2.0", 
upstream: "http://172.24.0.2:5280/http-bind?room=test1", 
host: "server.example.com:8443", referrer: "https://server.example.com:8443/test1"

The containers I believe are setup properly with the correct ports:

CONTAINER ID        IMAGE                       COMMAND             CREATED             STATUS              PORTS                                              NAMES
05e4d5b114e5        jitsi/jicofo:stable-5076    "/init"             16 hours ago        Up 16 hours                                                            docker-jitsi-meet-stable-5076_jicofo_1
4b1a87f48ab8        jitsi/jvb:stable-5076       "/init"             16 hours ago        Up 16 hours         0.0.0.0:4443->4443/tcp, 0.0.0.0:10000->10000/udp   docker-jitsi-meet-stable-5076_jvb_1
71b3ac4ef35b        jitsi/prosody:stable-5076   "/init"             16 hours ago        Up 16 hours         5222/tcp, 5280/tcp, 5347/tcp                       docker-jitsi-meet-stable-5076_prosody_1
3a3c7ae78d0c        jitsi/web:stable-5076       "/init"             16 hours ago        Up 16 hours         0.0.0.0:8000->80/tcp, 0.0.0.0:8443->443/tcp        docker-jitsi-meet-stable-5076_web_1

These are the Prosidy container logs. The prosidy container is at the 172.24.0.2 IP address:

[services.d] done.
startup             info	Prosody is using the epoll backend for connection handling
portmanager         info	Activated service 'component' on [*]:5347
general             info	Starting conference duration timer for muc.meet.jitsi
conferenceduration.meet.jitsi:conference_duration_component  info	No muc component found, will listen for it: muc.meet.jitsi
portmanager                                                  info	Activated service 'c2s' on [::]:5222, [*]:5222
portmanager                                                  info	Activated service 'legacy_ssl' on no ports
portmanager                                                  info	Activated service 'http' on [::]:5280, [*]:5280
portmanager                                                  info	Activated service 'https' on no ports
conferenceduration.meet.jitsi:conference_duration_component  info	Hook to muc events on muc.meet.jitsi
general                                                      info	Starting speakerstats for muc.meet.jitsi
speakerstats.meet.jitsi:speakerstats_component               info	Hook to muc events on muc.meet.jitsi

When running netstat however, I cannot find prosidy listening on the 5280 port.

I made very little changes in the .env file, only changin the remote address. I tried the installation on both a remote CentOS 8 server, as well as a local one, but got the same error on both.

Any advice and suggestions would be appreciated!