[docker-jitsi-meet] No audio + video with 3+ people with my own certificate


to get rid of the browser warnings (Chromium), I created my own CA and signed my own certificate with it using this guide: https://stackoverflow.com/questions/7580508/getting-chrome-to-accept-self-signed-localhost-certificate/60516812#60516812 . Then I replaced the cert.crt and cert.key in ~/.jitsi-meet-cfg/web/keys/ with the resp. files of my own cerificate.

Everything works fine with two participants, but as soon as a third one joins, everyone loses their video and audio. If afterwards there are only two people left again, their audio and video returns.

I don’t know much about certificates and Jitsi internals. Could someone please help me to include my own CA-signed certificate into the Jitsi Docker configuration?


Do the same test with 2 participants from your mobile removing the peer to peer and you will see you will have the same problem.

put this with a space after the = and without <> :
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS= my_vps_local_ip_addr
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS= my_public_ip_addr

1 Like

I’m not expert either, but the fact that it works for 2 people, makes me think it utilises the a P2P connection; the clients stream their audio and video directly to each other. This is a feature of Jitsi Meet to minimise the load of the server (I guess).

Read more about TURN (p2p):

I’m not sure what goes wrong for you, just wanted to point out the P2P feature.

1 Like

@jbeunel: Thanks, but where should I put it? Into the .env file or somewhere unter .jitsi-meet-cfg?

@get-it-done: Yeah, I thought about the change from E2E to “mere” SSL, too, but I don’t know what to do with it.

Update: I found a possible place for the two lines, changed their values to the public url and the local ip of my jitsi server, and it worked with three people yesterday (plus a second connection from another browser tab on one machine).

@all: The correct place is $HOME/.jitsi-meet-cfg/jvb/sip-communicator.properties

@jbeunel: Thanks!

Yes it’s in SIP-communicator properties sory for the delay.
I’m happy if it’s working for you.

1 Like

No problem, it took a day for me to realize I could just look them up on the web. :*)

Thanks again.

Unfortunately, the problem still exits partially. After running for a couple of hours, the problem returns that with 3+ people, all remote video+audio goes black.

Restarting the server solves the problem until it returns after some time. Any ideas?

edit: 3+ people, not 2+ people

edit 2: Ah, it happens after I get a new IP from my ISP. So a workaround would be to restart the Jitsi server after that happens. But it is still an annoying effekt. So, any help with this would be appreciated.

FYI: Only the WAN IP changes, not the LAN IP.

It could be memory capacity on your server. I saw a graph recently that indicated 4Gb were consumed over about (IIRC) an hour.

Hi Windsurfer, thanks for your reply. The problem is directly connected to a changed WAN IP of my internet connection (see edit #2 in my last post) It doesn’t depend on the uptime of the server. If I start the server, it works. If I change my public IP right away by reconnecting my internet connection, the problem appears until I restart the server again. It doesn’t look like a memory problem to me, as it is directly connected to the IP change.

If I’m missing something, please feel free to elaborate.

Hello, I didn’t seem to find $HOME/.jitsi-meet-cfg/jvb/sip-communicator.properties

Could this be in a different directory?

Are you using the Docker installation from https://github.com/jitsi/docker-jitsi-meet ?

If not, your Jitsi version may use different configuration directories.

No, I’m using the regular installation from https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md

I only found it in /etc/jitsi/videobridge/sip-communicator.properties and tried tinkering on this with no luck, so when I saw your reply I thought there was another sip-communicator.properties in a different directory.

Anyway, is it recommended to use the Docker version instead of the regular one?

I don’t know the exact differences, the Docker version was easier to install and worked from the start. I also tried the normal installation, but it required too many new packages to install for my taste, and didn’t even work on my Ubuntu Server 18.04 after that, so I removed it again and stayed with the Docker one.

What file are you editing here and what it its location?