Docker Jitsi and TURN installation doesn't work outside network

Hi everyone,

I’ve configure a jitsi server using docker intallation with this tutorial.

In my network, everything work fine with two and more users.

So, I decided to publish the jitsi service on internet to use it outside our network. When a user outside the network join the meeting, we can’t see and hear him.

I decided to install a coTURN server to tranfert all video and audio data through this server. The coturn server is in the network 10.0.0.1 and the jitsi server is on the network 179.0.0.1. So, both of the server are separate in my network.

I think my coturn server is well configure. I share you the test I’ve made with this site :

My turnserver.conf file is configured like this:

realm=turn.mydomain.org
server-name=name-of-the-server
fingerprint
listening-ip=0.0.0.0
external-ip=my-external-ip
listening-port=3478
min-port=10000
max-port=200000
log-file=/var/log/turnserver.log
verbose
user=user:test
lt-cred-mech

In my jitsi docker-compose.yml file, I configured the turn settings like this:

- TURN_CREDENTIALS=mypassword
- TURN_HOST=10.0.0.1
- TURNS_HOST=10.0.0.1
- TURN_PORT=3478
- TURNS_PORT=3478
- TURN_TRANSPORT

On the firewall, I opened the ports 3478/tcp, 5349/tcp, 443/tcp and 10000-20000/udp for the TURN server.
For the Jitsi server, I opened the ports 443/tcp, 8443/tcp and 10000/udp.

Here are my questions :

  • Why the user outside the network can’t see and hear the orthers users ?
  • Which parameters do I have to change ?

I hope I’ve made myself clear. If you want more explications or details, ask me and I’ll try to tell you.

Thanks in advance for the help :slightly_smiling_face:

I think you complicated things by adding TURN. You shouldn’t need it.

Have you configured JVB_ADVERTISED_IPS to point to your public IP?

I’ve configured it like this :

JVB_ADVERTISED_IPS=My_Public_IP

But nothing change unfortunatly.

You think I can configured the jitsi server without a TURN server ? How can the video and audio past through the firewall without TURN server ?

You’ll need to open your firewall, of course. Did you do that? This is necessary also if you have the TURN server behind the firewall.

Yes, I openned all the ports specify in the original post.

Does my configuration of turnserver.conf file and the docker-compose.yml file seem correct ?
Maybe, ma turn server and my jitsi server can’t communicate together.

As I said, I’d focus on getting it working without the TURN server first. The add it once you are sure all works fine.