Docker Jibri - Not showing in Browser

Hi all, new here :slight_smile:

I love Jitsi but am having issues with getting Jibri to work, I can’t see any major errors in the log and it says its connecting to the MUC yet it does not show in browser.

I’m aware there’s another post about this similar issue but it is an absolute mess to look at.

I ran it using Sudo as a non-root user.
Let me know if I’m missing something obvious, and I am ready to provide any additional info required to help resolve this.

Here are my logs from the Jibri container:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 01-set-timezone: executing...
[cont-init.d] 01-set-timezone: exited 0.
[cont-init.d] 10-config: executing...
chmod: cannot access '/config/finalize.sh': No such file or directory
[cont-init.d] 10-config: exited 0.
[cont-init.d] done.
[services.d] starting services
_XSERVTransicewm-session: using /root/.icewm for private configuration files
mkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.

X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
Current Operating System: Linux 88dd71a93bcf 4.15.0-101-generic #102-Ubuntu SMP Mon May 11 10:07:26 UTC 2020 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-101-generic root=UUID=8509fe04-d91c-410a-9087-c5d34537d3ae ro console=tty1 console=ttyS0
Build Date: 03 November 2018  03:09:11AM
xorg-server 2:1.19.2-1+deb9u5 (https://www.debian.org/support)
Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/tmp/xorg.log", Time: Tue Jun  2 21:39:21 2020
(++) Using config file: "/etc/jitsi/jibri/xorg-video-dummy.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
[services.d] done.
IceWM: using /root/.icewm for private configuration files
icewmbg: using /root/.icewm for private configuration files
2020-06-02 21:39:23.409 INFO: [1] org.jitsi.jibri.Main.main() Jibri run with args [--config, /etc/jitsi/jibri/config.json]
2020-06-02 21:39:23.413 INFO: [1] org.jitsi.jibri.Main.main() Using config file /etc/jitsi/jibri/config.json
2020-06-02 21:39:23.430 INFO: [1] org.jitsi.jibri.Main.main() Using port 3333 for internal HTTP API
2020-06-02 21:39:23.432 INFO: [1] org.jitsi.jibri.Main.main() Using port 2222 for the HTTP API
icewmtray: using /root/.icewm for private configuration files
2020-06-02 21:39:25.917 INFO: [1] org.jitsi.jibri.Main.loadConfig() Parsed config:
JibriConfig(recordingDirectory=/config/recordings, singleUseMode=false, enabledStatsD=true, finalizeRecordingScriptPath=/config/finalize.sh, xmppEnvironments=[XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[xmpp.meet.jitsi], xmppDomain=meet.jitsi, controlLogin=XmppCredentials(domain=auth.meet.jitsi, username=jibri, password=b14d414fc3efbbd3d8f4a70c640e40e2), controlMuc=XmppMuc(domain=internal-muc.meet.jitsi, roomName=jibribrewery, nickname=jibri-instanse-088960612), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.meet.jitsi, username=recorder, password=510669b4af7570f8eadc7c21639a7d0a), stripFromRoomDomain=muc., usageTimeoutMins=0, trustAllXmppCerts=true)])
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
2020-06-02 21:39:28.001 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.internal.InternalHttpApi will be ignored.
2020-06-02 21:39:28.653 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2020-06-02 21:39:28.658 INFO: [1] org.jitsi.xmpp.mucclient.MucClientManager.log() Setting a presence extension: org.jitsi.xmpp.extensions.jibri.JibriStatusPacketExt@771158fb
2020-06-02 21:39:28.673 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on xmpp.meet.jitsi with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[xmpp.meet.jitsi], xmppDomain=meet.jitsi, controlLogin=XmppCredentials(domain=auth.meet.jitsi, username=jibri, password=b14d414fc3efbbd3d8f4a70c640e40e2), controlMuc=XmppMuc(domain=internal-muc.meet.jitsi, roomName=jibribrewery, nickname=jibri-instanse-088960612), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.meet.jitsi, username=recorder, password=510669b4af7570f8eadc7c21639a7d0a), stripFromRoomDomain=muc., usageTimeoutMins=0, trustAllXmppCerts=true)
2020-06-02 21:39:28.676 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2020-06-02 21:39:28.711 FINE: [19] org.jitsi.xmpp.mucclient.MucClient.log() Initializing a new MucClient for [ org.jitsi.xmpp.mucclient.MucClientConfiguration id=xmpp.meet.jitsi domain=auth.meet.jitsi hostname=xmpp.meet.jitsi username=jibri mucs=[jibribrewery@internal-muc.meet.jitsi] mucNickname=jibri-instanse-088960612 disableCertificateVerification=true]
2020-06-02 21:39:28.747 WARNING: [19] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2020-06-02 21:39:28.910 FINE: [19] org.jitsi.xmpp.mucclient.MucClient.log() [MucClient id=xmpp.meet.jitsi hostname=xmpp.meet.jitsi] about to connect and login.
2020-06-02 21:39:28.970 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.jibri.api.http.HttpApi will be ignored.
2020-06-02 21:39:29.561 INFO: [19] org.jitsi.xmpp.mucclient.MucClient.log() [MucClient id=xmpp.meet.jitsi hostname=xmpp.meet.jitsi] connected
2020-06-02 21:39:29.718 FINE: [19] org.jitsi.xmpp.mucclient.MucClient.log() [MucClient id=xmpp.meet.jitsi hostname=xmpp.meet.jitsi] authenticated, b=false
2020-06-02 21:39:29.722 FINE: [19] org.jitsi.xmpp.mucclient.MucClient.log() [MucClient id=xmpp.meet.jitsi hostname=xmpp.meet.jitsi] about to join MUCs.
2020-06-02 21:39:29.789 INFO: [19] org.jitsi.xmpp.mucclient.MucClient.log() Joined MUC: jibribrewery@internal-muc.meet.jitsi
2020-06-02 21:39:29.798 FINE: [30] org.jitsi.xmpp.extensions.DefaultPacketExtensionProvider.parse() Could not add a provider for element busy-status from namespace http://jitsi.org/protocol/jibri
2020-06-02 21:39:29.799 FINE: [30] org.jitsi.xmpp.extensions.DefaultPacketExtensionProvider.parse() Could not add a provider for element health-status from namespace http://jitsi.org/protocol/health