Docker Jibri Chrome ssl error

hi there,

Im trying to setup Jibri on a docker deployment and this error is causing the recordings to stop:

2021-08-04 00:24:15.893 SEVERE: [103] org.jitsi.jibri.selenium.JibriSelenium.log() An error occurred while joining the call
org.openqa.selenium.WebDriverException: : Failed to read the ‘localStorage’ property from ‘Window’: Access is denied for this document.

Im aware this is a commune issue related to the self signed ssl certificate and there are several posts on the subject. But im only setting an environment for testing proposes. So i have no problem removing the chrome ssl security but i don’t now how.

in a regular installation it is possible to add a flag so chrome ignore ssl certifcate problems:

in /etc/jitsi/jibri/jibri.conf

chrome {
  // The flags which will be passed to chromium when launching
  flags = [
    "--use-fake-ui-for-media-stream",
    "--start-maximized",
    "--kiosk",
    "--enabled",
    "--disable-infobars",
    "--autoplay-policy=no-user-gesture-required”,
    "--ignore-certificate-errors”,
    "--disable-dev-shm-usage”,
    "--no-sandbox"
  ]
}

it’s any way to do it on a docker deployment???

Thanks on advance.

Double-quote is mistyped in the pasted config. Maybe it’s wrong in your config too

thanks for the answer. but im using docker deployment. what i need i a way to do remove ssl security but in docker.

this should be "--ignore-certificate-errors"

there are two options :-

  1. Get a ssl certificate for your public url.
  2. Try this example and add "--ignore-certificate-errors" here. Make sure to change the networking part as per your config and add the required config before spinning up the container.

first thanks for the answer.

this is my jibri.yml but is not working

version: ‘3’

services:
jibri:
image: jitsi/jibri:stable-5963
restart: ${RESTART_POLICY}
volumes:
- ${CONFIG}/jibri:/config:Z
- /dev/shm:/dev/shm
cap_add:
- SYS_ADMIN
- NET_BIND_SERVICE
devices:
- /dev/snd:/dev/snd
environment:
- PUBLIC_URL
- XMPP_AUTH_DOMAIN
- XMPP_INTERNAL_MUC_DOMAIN
- XMPP_RECORDER_DOMAIN
- XMPP_SERVER
- XMPP_DOMAIN
- JIBRI_XMPP_USER
- JIBRI_XMPP_PASSWORD
- JIBRI_BREWERY_MUC
- JIBRI_RECORDER_USER
- JIBRI_RECORDER_PASSWORD
- JIBRI_RECORDING_DIR
- JIBRI_FINALIZE_RECORDING_SCRIPT_PATH
- JIBRI_STRIP_DOMAIN_JID
- JIBRI_LOGS_DIR
- DISPLAY=:0
- TZ
CHROMIUM_FLAGS: “–ignore-certificate-errors”
depends_on:
- jicofo
networks:
meet.jitsi:

trows a error lunching the container

you can’t use CHROMIUM_FLAGS in this configuration that’s why I have shared the link. this jibri(file you have shared) still uses config.json not jibri.conf hence configuring chromium flags using env variable isn’t there yet.

ok. by this point i think is better to get the certificate. but for some reason i can get it using lets encrypt. can you suggest a guide to do it?

thanks

set it to true and spin up the container again. you can follow jitsi-handbook for more info.

im triying. but i keep getting this error:

There is a limit (IIRC it’s 5) while requesting a certificate from Let’s Encrypt. It seems that you requested many times for the same domain. Try tomorrow or try using another domain.

thanks i tried later and this was the result.

im new to this. Do i need to have a prerequisite for Let’s encrypt to work?

Thanks on advance

Are you really going through your logs?? check the logs again.

yes, A domain, A public-ip and DNS entry

But i only need to setup a local test environment. is no other way???