Docker Authentication

Hello All,

im running a docker install of jitis meet and and im looking for /etc/jitsi/meet/ location.

can someone streer me in the right direction.

@Michelb855 did you find the answer?

In a default docker setup, the configuration files are placed in a hidden folder inside your home directory, the default value is ~/.jitsi-meet-cfg and is set in your .env file:

The config.js file can be found in ~/.jitsi-meet-cfg/web/config.js

yeah, I didn’t have the folders created when I did my docker-compose up -d. all I did to get it to work was to create the folders that I missed and in my .env file I change auth guests and type then a docker-compose restart. jumped into my prosody container and added a user

create folders

mkdir -p ~/.jitsi-meet-cfg/{web/letsencrypt,transcripts,prosody,jicofo,jvb,jigasi,jibri}

edited my jitis.env file

# Enable authentication

# Enable guest access


# Select authentication type: internal, jwt or ldap

start your container as you would.

in my case

docker-compose up -d

head into the prosody container bash shell

docker exec -it containerId /bin/bash

command for user

prosodyctl --config /config/prosody.cfg.lua register TheDesiredUsername meet.jitsi TheDesiredPassword

Thank you!

On my setup, those folders are automatically created if not present when the container starts, as the “IMPORTANT” note here states. Does it not work that way for you?


I set my .env like the example above and next I go to my Prosody container and run a command to create a new user.

But when I do test I faced with audio issue(can’t hear each other) in this case:

  1. Create a new room by guest user and get “waiting host notification”
  2. Connect to this room by Authorized user
  3. Get stack with no audio issue - we just can’t hear each other

But if I try to create a room by authorized user and next guest users join that everything works well

What should I do?

I use jitsi-meet by docker-compose install (latest images)
in my .env I only change some rows:


Anything else no change