Do I need to change XMPP_DOMAIN XMPP_AUTH_DOMAIN in .env for setting JIBRI

I have hosted dockerized Jitsi Meet server, keeping default values for XMPP_DOMAIN, XMPP_AUTH_DOMAIN, XMPP_MUC_DOMAIN, XMPP_INTERNAL_MUC_DOMAIN, just changed domain for LetsEncrypt, it’s running well.

But now I am trying to configure Jibri on another VM following git readme. I have made changes in web container(config.js), prosody container(prosody.cfg.lua) and also jicofo.

But when I try to register user for Jibri in prosody, it throws error hostname not found in config.

What am I missing here?

Have you tried this PR? https://github.com/jitsi/docker-jitsi-meet/pull/54

Thanks Saghul. The PR seems very interesting and I shall give it a try. But I believe my question shall still remain i.e. in configuration, for example (in env file - # Internal XMPP domain for authenticated services.
XMPP_AUTH_DOMAIN=auth.meet.jitsi) Do I need to change Auth domain to point to my domain where I have hosted jitsi docker i.e auth..com … and similarly change all such env variables?

No, you don’t need to change that. Those settings are internal.

The reason I am asking this question is, I am blocked at Jibri setup step(https://github.com/jitsi/jibri) at prosody side,
when it says create user for Jibri using prosodyctl,

prosodyctl register jibri auth.yourdomain.com jibriauthpass

Says hostname not found in config.js

You can use the internal domain there.

Thanks, it worked for

prosodyctl register recorder recorder.yourdomain.com jibrirecorderpass

Now for

prosodyctl register jibri internal.auth.yourdomain.com jibriauthpass

now it says,

Error: No data storage active

We have tried setting storage to “internal”, “null” and “memory”

modules_enabled = {
                 "ping";
                     }
                         storage = "internal"
                             muc_room_cache_size = 1000