Do I need octo?

Hi
we have installed jitsi meet / VB2 and we have tested it with ~15users on a 2vcpu/4G ram AWS t3.medium instance.
it was working well.
however, with ~50 users it was problematic.
the users didn’t see any videos after around 30users, once the application core dumped.

according to the monitoring the server wasn’t running out of ram, nor the network bandwith, but the cpu was running ~95%

am I right, that the users didn’t see video because of low cpu? (it was just a test)
if we for example choose a c5.large4xl instance with 16vcpu, would it be enough or should we use octo?
to be honest, it’s not clear that octo will help spreading the NETWORK load or the CPU load (or both)?

bonus question: I can’t enable statistics on port 8080 with the configurations below

JVB_OPTS="–apis=rest,xmpp"

org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=“muc”,“ubsub”,“callstats.io”,“colibri”

thank you for your help:)

New here… I might be wrong.

With that said: Octo is only needed for having multiple JVBs in different regions, where users get directed to the JVB closest to them.

You can run multiple JVBs without octo though, which is probably what you want to do. To do this:

  1. Boot additional servers that just have jitsi-videobridge2 installed
  2. Configure them to join the MUC from the master server
  3. That’s it!

No idea about the stats, sorry.

thank you, I will check it out

Add more JVB.
Either via an autoscaling or just provision more so you have 1 Jitsi-meet (+prosody, +jicofo) and N JVB where N >= 1
You can use MUC for this and the Jitsi Meet server will load balance your users across several video bridges.
You still have 1 point of failure: the Jitsi-Meet server, but most of the stress is focussed on the video bridges so having multiple of them is quite important.

Have a look at this link: Multiple videobridges howto?

It would be super useful if you generated a flame graph of your server, then we can look at it and discuss what part of the system is eating the CPU cycles and how to fix it.

possible fixes are: tune or disable swap, tune and disable logging causing stalls inside videobridge.

1 Like

Can you please help me to fix this issue. My issue contains this post. Need to test that whether it's working or not after enabling OCTO . Thank you.