Dns record & IP address

Hi, I have installed Jitsi on a VPS with domain name= “mypersonaljitsi.domain.name”. The VPS has the IP address:
“mypersonalIP-address”
When I approach the domain with “mypersonaljitsi.domain.name”, Jitsi starts. When I approach the domain with the associated “mypersonalIP-address”, I see a welcome screen, stating that NGINX has been correctly installed, but needs further configuration.
I would like to join my server from another domain by editing the DNS records. of that other domain. But if I edit the DNS records to include “mypersonalIP-address”, then also I get the same NGINX welcome screen. Anyone have an explanation or a solution?

In your nginx configuration (/etc/nginx/sites-enabled/yourdomain.conf), one of the first lines says “server_name”. This is a list of the space-delimited hostnames that the server will accept. Anything not in this list sees the default nginx page.

You need to:

  1. Edit /etc/nginx/sites-enabled/yourdomain.conf
  2. On the server_name lines (there should be two of them), add in all of the names used by this server. E.g., “server_name mypersonaljitsi.domain.name mypersonalIP-address;”
  3. Save the file.
  4. Reload nginx (sudo service nginx reload)
1 Like

Sorry for not reacting earlier and thank you for your suggestion. I will try to get it working.

Thank you, Emrah for your answer. Being an absolute newbie, I can only grasp the headlines in your posting. For the details I will have to get back to someone who can fill in the details for me, such as exact texts to edit in exact what file etc. Eventually I will get to it, but it will take time. At the same time, your posting is an inspiration to learn more.