Disconnecting every 30 seconds!

I am trying to install an internal only jitsi setup. I have followed the quick install and when ever I start a conference it disconnects every 30 seconds or so and then reconnects. I’ve been at this 2 days straight! HELP! :slight_smile:

I think your videobridge is not working.

The following extra lines need to be added to the file /etc/jitsi/videobridge/sip-communicator.properties if you are behind a NAT

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=Local.IP.Address
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=Public.IP.Address

https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration

Yeah I have that… BUT I wasn’t sure what to put in as my Public IP since this setup will be internal only. Would I put in the internal IP? Currently I put the internal IP in both places.

Thanks for any help you can provide! I really appreciate it. I have literally reverted back to my original VM about 15 times! Each time trying something slightly different but each time getting the same disconnect issue.

I’m also getting this with a fresh install each time…

Processing triggers for ufw (0.36-0ubuntu0.18.04.1) …
Processing triggers for ureadahead (0.100.0-21) …
Processing triggers for libc-bin (2.27-3ubuntu1) …
Errors were encountered while processing:
jitsi-meet-prosody
jitsi-meet
jitsi-meet-turnserver
W: http://us.archive.ubuntu.com/ubuntu/pool/universe/o/openjdk-8/openjdk-8-jre-headless_8u252-b09-1~18.04_amd64.deb: Automatically disabled Acquire::http::Pipeline-Depth due to incorrect response from server/proxy. (man 5 apt.conf)
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have tried various installs from quick install, to jitsi video installs, to manual install… I have wasted my entire weekend doing this! I am super frustrated. I now will have to go back to using Skype because I can’t get this to work. :frowning:

I installed Jitsi server [ fqdn (jitsi.ten.tld)] for Local area network only
Works fine if access using fqdn (jitsi.ten.tld) but once accessing it using ip address of server, webcam and mic were not functional. So i opted for a solution
Just configure all LAN computers host files (on windows c:\Windows\System32\Drivers\etc\hosts) and add your fdqn with server ip (in my case 192.168.8.100 jitsi.ten.tld)
Now i can access and join meeting using fdqn instead of ip address on my local area connected systems and it works like a charm.
Hope it will help you all.