Disabling private messages

Hi

Is it possible to disable private messaging in a self-hosted instance of Jitsi-meet?
The ability to message all participants in a meeting is great and we’d like to keep that, but in my particular use case we can’t let individual users message each other.

Thanks

People can’t make private messages as far as I notice :upside_down_face:

What do you mean?

…I want to disable this
image

Ow, I never noticed that feature xD

In case you found it, let me know, I didn’t found it in configuration files.

Inspecting the page got me to the privmsglink button, so it should be something like privmsg but I don’t find it neither in the interface_config.js neither in the domain.live-config.js

It must be somewhere else.

Hi,
Here is a quick and dirty way I found to do so.
Edit the all.css file : /usr/share/jitsi-meet/css/all.css
and add at the end :
[id*="privmsglink_"]{display:none}

Hi,

I’m using iframeAPI and I need to disable private messages too.
Is there any way to do this when using iframeAPI?

@damencho Is it possible to disable private message between individual users using Jitsi external API / iframeAPI ?

@Sreeni, @alanrmoreira,

You should be able to use the API to hide buttons by overriding the available TOOLBAR_BUTTONS (removing ‘chat’) in the interfaceConfigOverwrite property.

From the Handbook: https://jitsi.github.io/handbook/docs/dev-guide/dev-guide-iframe#api

You can override options set in config.js and interface_config.js via configOverwrite and interfaceConfigOverwrite respectively.

For example:

...

const myOverwrite =
{
  'TOOLBAR_BUTTONS': [
        'microphone', 'camera', 'closedcaptions', 'desktop', 'fullscreen',
        'fodeviceselection', 'hangup', 'profile', 'recording',
        'livestreaming', 'etherpad', 'sharedvideo', 'settings', 'raisehand',
        'videoquality', 'filmstrip', 'invite', 'feedback', 'stats', 'shortcuts',
        'tileview', 'videobackgroundblur', 'download', 'help', 'mute-everyone', 'security'
    ]
};

const options = 
{
    ...
    interfaceConfigOverwrite: myOverwrite,
    ...
};

const api = new JitsiMeetExternalAPI(domain, options);
...

Hi @corby this way all chats are disabled in screen (public and private).
Please, check the image so you can see what I mean.

Thank you!