Disable Noise Cancelling

Hello,

I can’t find any solution for my question, so I decided to ask here directly.
I set up a room and want to share my screen. My audio output is routet through the microphone input within the options from jitsi meet. It works fine, for a couple of seconds. Than the sound starts to become bad. It sounds like there is a bad noise cancelling trying to do it’s work.

Is there a way to disable it?

2 Likes

First, I must give a big thank you for the Jitsi creators and community.
Due to the coronavirus outbreake we are forced to seek communication means,
and Jitsi-meet seems excellent option. I really would like to stay in FOSS domain.

Thank you developers and staff for being very helpful. (damencho, emcho, bbaldino, Boris, and others)
Until now I was trying to solve all my problems without asking, but now I am really lost.

It is crucial for our meetings also to play multimedia files, like videos or audio.
I was able to find a quick and neat “hack” with the help of Virtual Audio Cable, and I have routed audio from system to mic input of jitsi, we can dedicate one “participant” for that, only for playing our media.

But exactly as Fabrice_Lezzi stated, the quality of sound turns very bad after few seconds, and I can do nothing about it.

The best solution for us will be to implement very simple mediaplayer into Jitsi-meet.
Maybe just a button for opening a mediafile and playing it.
I see it is doable, because when playing the stream from Youtube the sound stays perfect. (thank you for that Youtube functionality, too, but we cannot upload our content to Youtube)

Will you please point me to some usable workaround?

Thank you in advance,
Andy Salay

1 Like

You can disable some audio processing like https://meet.jit.si/mytestroom#config.disableAP=true or appending #config.stereo=true

3 Likes

Wow, this is support level!
Immediate!
Is this per participant, or global?

participant

So. I joined the mediaplayer participant with that option,
is it correct, this is the suffix?
#config.disableAP=true
and does it come right after address string
https://ourdomain.com/TEST ?

The sound seems really a bit better, the jitters are gone, but the sound is still quite distorted and lacks clearness of the original. What else can I try?

(edit: grammar and typos)
edit2: The sound quality resembles youtube 144p sound, but in comparison to youtube there is an additional “shivering” or “tremolo” in the sound.

I am trying this one in the meantime, but results are not sufficient, sound is still shivering.

Sorry, hope this will not be considered spam.
I am doing my homework and try to research possible causes.
Just to let to know others, I found this


and tried the options. Disabled p2p on the server.
According to sound it seems the distortion is caused by codec settings, 70 kbit/s for stereo is really low for quality music, and it seems real, that the distortions are compression artifacts.

Any chance for some solution? Force bitrate?

How is youtube sharing made? Why the sound quality is much better?

1 Like

Interesting. Is there any server-side sound processing or everything is just browser based?

Would be able to have a local media player, agree 100%

Hi, can we denoise each frame of audio pcm data using rnnoise from onAudioProcess. RNNoise seems to detect only voise activity in a certain frame of pcm data rather than denoising.

Thanks

@damencho sometimes we feel extra noice in Conference which is not human noice and not even created notice from participant side. What could cause this… any idea to look for in custom installation…

@innovation if the client is overloaded then you will hear clicking noise as the client is unable to handle audio fast enough.