Disable logging for privacy

I see that there are discussions on this, but they are pretty stale (2016).
I would like to have the option to disable all logging to help with privacy on a production system.
Looking for Jitsi specific advice, I have found info for disabling logging for Turn, Prosody, nginx, etc…

Two questions:

  1. Is the best way to disable ALL logging is to set in /etc/jitsi/config

to /dev/null instead of /var/log/jitsi? Will that take care of both jvb.log and jicofo.log, or is there a preferable method to this rather brute force method?

  1. Similarly, if I only wanted to log errors (instead of throwing everything into /dev/null), is there a way to do that?

I was wandering around github looking for documentation on the log files, didn’t see it in one place, if it is answered there, you can just point me to the appropriate place. Thanks!

I didn’t try but there is a “.level=” line in the logging.properties files. The default value is INFO. Maybe WARNING or ERROR is better for your case.

in 2016 Jitsi-meet was probably using jetty as web server, now it’s nginx so you have to take care of nginx logging too; it’s documented everywhere so I don’t see the need to search the internet for you :slight_smile:

Got nginx, as stated in the post. I am asking only about jvb.log and jicofo.log. Do you have any ideas on that?

ah yes, sorry. About jvb I have nothing to add to what @emrah said; about jicofo log I’m not sure there is much to hide - as far as I can tell, the only personal info there is the username creating the conference (if you are serious about anonymity, you should host an open instance anyway), and no IP address, no nickname. Not much to identify someone.

Do you know what the syntax is of the allowed values are?
Where would I look to find what options and the syntax of those options?

I tried 1 - set the location to /dev/null in config for both jicofo and videobridge, and did a rm * in the /var/log/jitsi directory and reboot. But the files still appeared… I wonder what the variable does…


So, I could not get /dev/null to work…

However, if I set all the levels in logging .properties to OFF, that makes jicofo empty, and jvb.log just has very minor information I could live with.

Does anyone know if I have to modify all the .level commands in those files (that is what I tested), or can I just set it for .level=OFF or just java.util.logging.ConsoleHandler.level=OFF?