Disable Grant Moderator

Hello,

I wanted to disable grant moderator option in installation of jitsi meet.

I went to this location /etc/jitsi/meet/

and opened your-domain-config.js file.

over there i set up the disableGrantModerator=true

but still the option to grant moderator is showing and working, Please help me what i am doing wrong.

Thank you

There may be a cache issue. Try in a private session

tried that but still it is showing in private session.

you have a recent version right ? option was added circa May 2021.

Yes I got the recent version installed.

then it’s a mystery ;-). Could you post the relevant part of your config.js though ?

here you go

at this point it’s necessary to make absolutely sure that your config is really used; so if from your workstation you use

curl https://yourmeetdomain.yourtld/config.js | grep disableGrantModerator

(replace yourmeetdomain.yourtld by the appropriate value for your site of course)

you get

disableGrantModerator: true,

right ?

yes thats right

What’s the output of:

dpkg -l "jitsi-*" "jicofo*" "prosody*" | egrep '^ii'

Can you try disabling “Kick” and see if that works?

I tried that and disable kick doesn’t work either

Suspected as much. Looks like something is wrong with your config being picked up. Check nginx to make sure you have the right path, just in case…

let’s imagine even wilder things in your config :slight_smile:

curl https://yourmeetdom.yourtld/config.js | grep remoteVideoMenu

(replace yourmeetdom.yourtld by the appropriate value for your site of course)

you get only one instance of

remoteVideoMenu

right ?

Delete the trailing comma

I checked that and it does not seem to matter…(it would be logical it does, but logic and software are not always the same thing)

1 Like

then the following note from the Jitsi Meet config is useless

    // Allow all above example options to include a trailing comma and
    // prevent fear when commenting out the last value.
    makeJsonParserHappy: 'even if last key had a trailing comma'