Disable cert prosody

Hello,

I installed the lua module event_sync to get data of the rooms I also created a webhook to have the data.

I always had in the prosody log ‘API return 0’, when I displayed the repsonse_body in lua I had this message :

Apr 21 20:54:11 event_sync.meet.test.dev:event_sync_component warn API Response code 0. Will retry after 1s [certificate-verify-failed]

is there any way to disable this certificate check please

also i have this error in prosody.err

portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281

@damencho can you help me please

Under the hood, that module uses the net.http prosody module to make http requests which means you should be able to modify the code to pass in the insecure option in the options table. See:

https://prosody.im/doc/developers/net/http#httprequest_url_options_callback

The portmanager error message you quoted is unrelated and can probably be ignored. See:

Hello

thank you for your help, it’s workign

have any idea it’s possible to more user info like email or display_name ?

@shawn
thank you

Glad you solved your problem.

If your users use JWT to authenticate then the name and email from the token will get included in the payload.

Otherwise you can’t get that info without further work I’m afraid.

hello,

i dont use JWT,
maybe i will work on it, I need to work in lua side or in jitsi meet (react side) ?

thank you @shawn

In the prosody module, using lua, which will run on the server. Code you write in react will run on client side which you probably don’t want to trust to post content to your endpoint for data collection .