Disable all participants being moderators

I have tried using all the other community posts that I could find regarding this issue but none of them fixed my issue and this is stumping me on why it is happening. below is exactly (minus some obvious replacements) what my prosody config and as you can see muc_allowners is not enabled and I have tried adding it to modules_disabled and that didnt fix my issue.

-- plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }
plugin_paths = { "/var/www/meeting/jitsi-meet/resources/prosody-plugins/" }

-- asap_accepted_issuers = { "*" }
-- asap_accepted_audiences = { "*" }
-- domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = "mydomain";

external_service_secret = "64ALErbhbGVwGlhQ";
external_services = {
     { type = "stun", host = "mydomain", port = 3478 },
     { type = "turn", host = "mydomain", port = 3478, transport = "udp", secret = true, ttl = 86400, algorithm = "turn" },
     { type = "turns", host = "mydomain", port = 5349, transport = "tcp", secret = true, ttl = 86400, algorithm = "turn" }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
-- https_ports = { }; -- Remove this line to prevent listening on port 5284

-- https://ssl-config.mozilla.org/#server=haproxy&version=2.1&config=intermediate&openssl=1.1.0g&guideline=5.4
ssl = {
    protocol = "tlsv1_2+";
    ciphers = "cipher"
}

unlimited_jids = {
    "focus@auth.mydomain",
    "jvb@auth.mydomain"
}

VirtualHost "mydomain"
    -- enabled = false -- Remove this line to enable this host
    authentication = "anonymous"
    -- Properties below are modified by jitsi-meet-tokens package config
    -- and authentication above is switched to "token"
    -- app_id="appid"
    -- app_secret="appsecret"
    -- allow_empty_token = false;
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.
    ssl = {
        key = "/etc/prosody/certs/mydomain.key";
        certificate = "/etc/prosody/certs/mydomain.crt";
    }
    av_moderation_component = "avmoderation.mydomain"
    speakerstats_component = "speakerstats.mydomain"
    conference_duration_component = "conferenceduration.mydomain"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "external_services";
        "conference_duration";
        "muc_lobby_rooms";
        "muc_breakout_rooms";
        "av_moderation";
	"presence_identity";
    }

    c2s_require_encryption = false
    lobby_muc = "lobby.mydomain"
    breakout_rooms_muc = "breakout.mydomain"
    main_muc = "conference.mydomain"
    -- muc_lobby_whitelist = { "recorder.mydomain" } -- Here we can whitelist jibri to enter lobby enabled rooms

--VirtualHost "guest.mydomain"
--    authentication = "token"
--    c2s_require_encryption = false

Component "conference.mydomain" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        "polls";
        "token_verification";
	"token_affiliation";
        "muc_rate_limit";
    }

    admins = { "focus@auth.mydomain" }
    muc_room_locking = false
    muc_room_default_public_jids = true


Component "breakout.mydomain" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        "token_verification";
        "muc_rate_limit";
    }

    admins = { "focus@auth.mydomain" }
    muc_room_locking = false
    muc_room_default_public_jids = true

-- internal muc component
Component "internal.auth.mydomain" "muc"
    storage = "memory"
    modules_enabled = {
        "ping";
    }
    admins = { "focus@auth.mydomain", "jvb@auth.mydomain" }
    muc_room_locking = false
    muc_room_default_public_jids = true

VirtualHost "auth.mydomain"
    ssl = {
        key = "/etc/prosody/certs/auth.mydomain.key";
        certificate = "/etc/prosody/certs/auth.mydomain.crt";
    }
    modules_enabled = {
        "limits_exception";
    }
    authentication = "internal_hashed"

-- Proxy to jicofo's user JID, so that it doesn't have to register as a component.
Component "focus.mydomain" "client_proxy"
    target_address = "focus@auth.mydomain"

Component "speakerstats.mydomain" "speakerstats_component"
    muc_component = "conference.mydomain"

Component "conferenceduration.mydomain" "conference_duration_component"
    muc_component = "conference.mydomain"

Component "avmoderation.mydomain" "av_moderation_component"
    muc_component = "conference.mydomain"

Component "lobby.mydomain" "muc"
    storage = "memory"
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_default_public_jids = true
    modules_enabled = {
        "muc_rate_limit";
    }

I’m not sure what your issue is, but if you’re wondering why the first person to join a room is automatically assigned as moderator, that’s the auto-owner feature in Jicofo.

You can disable that in your jicofo config:

Search the forum for “enable-auto-owner” for more details.

the issue is what is in the title, every single participant is has the moderator role,

first person to join a room is automatically assigned as moderator

this is what i want but for some reason it isn’t.

:person_shrugging:

Usually it’s the allowners module that does that. But you mentioned you did not enable that so no idea what’s going on.

Can you share your jicofo.conf ?

I see you have token_verification and token_affiliation modules enabled. So you use JWT auth and you want to specify who becomes moderator from the token payload, but also for first person who joins to be automatically assigned as moderator?

the token_verification and token_affiliation is more so me trying to use jwt’s to achieve my goal but that led to me being unable to enable audio or video when i start a meeting with a jwt, so i scrapped that idea for now

# Jicofo HOCON configuration. See reference.conf in /usr/share/jicofo/jicofo.jar for
#available options, syntax, and default values.
jicofo {
  authentication: {
     enabled: true
     type: XMPP
     login-url: mydomain.com
  }
  xmpp: {
    client: {
      client-proxy: focus.mydomain.com
    }
    trusted-domains: [ "recorder.mydomain.com" ]
  }
  bridge: {
    brewery-jid: "JvbBrewery@internal.auth.mydomain.com"
  }
  conference: {
    enable-auto-owner = false
  }
}

this is my jicofo.conf I changed JWT to XMPP since I shelved the JWT idea I mentioned

That looks like you’re setting up XMPP-based auth in which case all authenticated users will be moderators, and if you enable anonymous login, then guests can also join but they won’t be moderators. Also, by default Jicofo has enable-auto-login enabled, which means once you’ve logged it, you will be automatically logged in the next time you visit and hence also become moderator.

I’m afraid I am still not clear what you end goal here is, and if when you say “all participants become moderators” are these participants guests or authenticated users.

right now i have everything else set to anonymous, since i am embedding the meetings in an iFrame and the ‘authentication’ happens through my website. so to answer your question in the jitsi sense i would say ‘participants are guests’. From you comment i am under the impression that if I remove the authentication block from my jicofo.conf, i would have my desired result?

That would be the default behaviour in a fresh install of Jitsi, yes. Anyone can join, and first person who joins become moderator. If moderator leaves, then the next person in line gets promoted to moderator.

If you undo everything you did, then with luck you can get back to that state :crossed_fingers:

I can’t quickly tell what you have changed, but at least these need to change:

Remove that ^

This should be false

This should be true.

And of course, don’t forget to restart Jicofo and Prosody after the changes :slight_smile:

do you happen to know any other files that would affect this that i can show here, to see if anything needs to be changed since made the changes you suggested and i still have the same behaviour

AFAIK, it’s Jicofo and Prosody (+plugins) that handles automatic moderator assignments. Perhaps share the following and someone might be able to spot what’s going on with your setup:

  1. /etc/jitsi/jicofo/jicofo.conf
  2. /etc/prosody/prosody.cfg.lua
  3. /etc/prosody/conf.d/YOURDOMAIN.cfg.lua

Please format code blocks properly as preformatted text or else it is really really hard to follow.
Disable_all_participants_being_moderators_-Developers-Jitsi_Community_Forum-_developers___users

It would also help a lot of you can give description of:

  • how you are testing, what behaviour you are seeing, and what you are expecting instead.
  • any custom code changes or plugins you have included.

Also, if you are in the position to start from a fresh install, that would probably save you a lot of time.

This is my jicofo.conf

# Jicofo HOCON configuration. See reference.conf in /usr/share/jicofo/jicofo.jar for
#available options, syntax, and default values.
jicofo {
  xmpp: {
    client: {
      client-proxy: focus.mydomain
    }
    trusted-domains: [ "recorder.mydomain" ]
  }
  bridge: {
    brewery-jid: "JvbBrewery@internal.auth.mydomain"
  }
}

This is my prosody.cfg.lua

-- Prosody Example Configuration File
--
-- Information on configuring Prosody can be found on our
-- website at https://prosody.im/doc/configure
--
-- Tip: You can check that the syntax of this file is correct
-- when you have finished by running this command:
--     prosodyctl check config
-- If there are any errors, it will let you know what and where
-- they are, otherwise it will keep quiet.
--
-- The only thing left to do is rename this file to remove the .dist ending, and fill in the
-- blanks. Good luck, and happy Jabbering!


---------- Server-wide settings ----------
-- Settings in this section apply to the whole server and are the default settings
-- for any virtual hosts

-- This is a (by default, empty) list of accounts that are admins
-- for the server. Note that you must create the accounts separately
-- (see https://prosody.im/doc/creating_accounts for info)
-- Example: admins = { "user1@example.com", "user2@example.net" }
admins = { }

-- Enable use of libevent for better performance under high load
-- For more information see: https://prosody.im/doc/libevent
--use_libevent = true

-- Prosody will always look in its source directory for modules, but
-- this option allows you to specify additional locations where Prosody
-- will look for modules first. For community modules, see https://modules.prosody.im/
-- For a local administrator it's common to place local modifications
-- under /usr/local/ hierarchy:
-- plugin_paths = { "/var//jitsi-meet/resources/prosody-plugins/" }

-- This is the list of modules Prosody will load on startup.
-- It looks for mod_modulename.lua in the plugins folder, so make sure that exists too.
-- Documentation for bundled modules can be found at: https://prosody.im/doc/modules
modules_enabled = {

	-- Generally required
		"roster"; -- Allow users to have a roster. Recommended ;)
		"saslauth"; -- Authentication for clients and servers. Recommended if you want to log in.
		"tls"; -- Add support for secure TLS on c2s/s2s connections
		"dialback"; -- s2s dialback support
		"disco"; -- Service discovery

	-- Not essential, but recommended
		"carbons"; -- Keep multiple clients in sync
		"pep"; -- Enables users to publish their avatar, mood, activity, playing music and more
		"private"; -- Private XML storage (for room bookmarks, etc.)
		"blocklist"; -- Allow users to block communications with other users
		"vcard4"; -- User profiles (stored in PEP)
		"vcard_legacy"; -- Conversion between legacy vCard and PEP Avatar, vcard
		"limits"; -- Enable bandwidth for XMPP connections

	-- Nice to have
		"version"; -- Replies to server version requests
		"uptime"; -- Report how long server has been running
		"time"; -- Let others know the time here on this server
		"ping"; -- Replies to XMPP pings with pongs
		"register"; -- Allow users to register on this server using a client and change passwords
		--"mam"; -- Store messages in an archive and allow users to access it
		--"csi_simple"; -- Simple Mobile optimizations

	-- Admin interfaces
		"admin_adhoc"; -- Allows administration via an XMPP client that supports ad-hoc commands
		--"admin_telnet"; -- Opens telnet console interface on localhost port 5582

	-- HTTP modules
		--"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
		--"websocket"; -- XMPP over WebSockets
		--"http_files"; -- Serve static files from a directory over HTTP

	-- Other specific functionality
		"posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
		--"limits"; -- Enable bandwidth limiting for XMPP connections
		--"groups"; -- Shared roster support
		--"server_contact_info"; -- Publish contact information for this service
		--"announce"; -- Send announcement to all online users
		--"welcome"; -- Welcome users who register accounts
		--"watchregistrations"; -- Alert admins of registrations
		--"motd"; -- Send a message to users when they log in
		--"legacyauth"; -- Legacy authentication. Only used by some old clients and bots.
		--"proxy65"; -- Enables a file transfer proxy service which clients behind NAT can use
}

-- These modules are auto-loaded, but should you want
-- to disable them then uncomment them here:
modules_disabled = {
	-- "offline"; -- Store offline messages
	-- "c2s"; -- Handle client connections
	-- "s2s"; -- Handle server-to-server connections
}

-- Disable account creation by default, for security
-- For more information see https://prosody.im/doc/creating_accounts
allow_registration = false

-- Debian:
--   Do not send the server to background, either systemd or start-stop-daemon take care of that.
--
daemonize = false;

-- Debian:
--   Please, don't change this option since /run/prosody/
--   is one of the few directories Prosody is allowed to write to
--
pidfile = "/run/prosody/prosody.pid";

-- Force clients to use encrypted connections? This option will
-- prevent clients from authenticating unless they are using encryption.

c2s_require_encryption = true

-- Force servers to use encrypted connections? This option will
-- prevent servers from authenticating unless they are using encryption.

s2s_require_encryption = true

-- Force certificate authentication for server-to-server connections?

s2s_secure_auth = false

-- Some servers have invalid or self-signed certificates. You can list
-- remote domains here that will not be required to authenticate using
-- certificates. They will be authenticated using DNS instead, even
-- when s2s_secure_auth is enabled.

--s2s_insecure_domains = { "insecure.example" }

-- Even if you disable s2s_secure_auth, you can still require valid
-- certificates for some domains by specifying a list here.

--s2s_secure_domains = { "jabber.org" }

-- Select the authentication backend to use. The 'internal' providers
-- use Prosody's configured data storage to store the authentication data.

authentication = "internal_hashed"

-- Select the storage backend to use. By default Prosody uses flat files
-- in its configured data directory, but it also supports more backends
-- through modules. An "sql" backend is included by default, but requires
-- additional dependencies. See https://prosody.im/doc/storage for more info.

--storage = "sql" -- Default is "internal" (Debian: "sql" requires one of the
-- lua-dbi-sqlite3, lua-dbi-mysql or lua-dbi-postgresql packages to work)

-- For the "sql" backend, you can uncomment *one* of the below to configure:
--sql = { driver = "SQLite3", database = "prosody.sqlite" } -- Default. 'database' is the filename.
--sql = { driver = "MySQL", database = "wordpress", username = "newuser", password = "password", host = "localhost" }
--sql = { driver = "PostgreSQL", database = "prosody", username = "prosody", password = "secret", host = "localhost" }
--sql_manage_tables = true
--default_storage = "internal"
--storage = {
--	accounts = "sql";
--}

-- Archiving configuration
-- If mod_mam is enabled, Prosody will store a copy of every message. This
-- is used to synchronize conversations between multiple clients, even if
-- they are offline. This setting controls how long Prosody will keep
-- messages in the archive before removing them.

archive_expires_after = "1w" -- Remove archived messages after 1 week

-- You can also configure messages to be stored in-memory only. For more
-- archiving options, see https://prosody.im/doc/modules/mod_mam

-- Logging configuration
-- For advanced logging see https://prosody.im/doc/logging
--
-- Debian:
--  Logs info and higher to /var/log
--  Logs errors to syslog also
log = {
	-- Log files (change 'info' to 'debug' for debug logs):
	info = "/var/log/prosody/prosody.log";
	error = "/var/log/prosody/prosody.err";
	-- Syslog:
	{ levels = { "error" }; to = "syslog";  };
}

-- Uncomment to enable statistics
-- For more info see https://prosody.im/doc/statistics
-- statistics = "internal"

-- Certificates
-- Every virtual host and component needs a certificate so that clients and
-- servers can securely verify its identity. Prosody will automatically load
-- certificates/keys from the directory specified here.
-- For more information, including how to use 'prosodyctl' to auto-import certificates
-- (from e.g. Let's Encrypt) see https://prosody.im/doc/certificates

-- Location of directory to find certificates in (relative to main config file):
certificates = "certs"

-- HTTPS currently only supports a single certificate, specify it here:
--https_certificate = "/etc/prosody/certs/localhost.crt"

----------- Virtual hosts -----------
-- You need to add a VirtualHost entry for each domain you wish Prosody to serve.
-- Settings under each VirtualHost entry apply *only* to that host.
-- It's customary to maintain VirtualHost entries in separate config files
-- under /etc/prosody/conf.d/ directory. Examples of such config files can
-- be found in /etc/prosody/conf.avail/ directory.

------ Additional config files ------
-- For organizational purposes you may prefer to add VirtualHost and
-- Component definitions in their own config files. This line includes
-- all config files in /etc/prosody/conf.d/

VirtualHost "localhost"

--VirtualHost "example.com"
--	certificate = "/path/to/example.crt"

------ Components ------
-- You can specify components to add hosts that provide special services,
-- like multi-user conferences, and transports.
-- For more information on components, see https://prosody.im/doc/components

---Set up a MUC (multi-user chat) room server on conference.example.com:
--Component "conference.example.com" "muc"
--- Store MUC messages in an archive and allow users to access it
--modules_enabled = { "muc_mam" }

---Set up an external component (default component port is 5347)
--
-- External components allow adding various services, such as gateways/
-- transports to other networks like ICQ, MSN and Yahoo. For more info
-- see: https://prosody.im/doc/components#adding_an_external_component
--
--Component "gateway.example.com"
--	component_secret = "password"
Include "conf.d/*.cfg.lua"

and this is my ‘mydomain’.cfg.lua

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }
-- plugin_paths = { "/var/www/meeting/jitsi-meet/resources/prosody-plugins/" }

-- asap_accepted_issuers = { "*" }
-- asap_accepted_audiences = { "*" }
-- domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = "mydomain";

external_service_secret = "64ALErbhbGVwGlhQ";
external_services = {
     { type = "stun", host = "mydomain", port = 3478 },
     { type = "turn", host = "mydomain", port = 3478, transport = "udp", secret = true, ttl = 86400, algorithm = "turn" },
     { type = "turns", host = "mydomain", port = 5349, transport = "tcp", secret = true, ttl = 86400, algorithm = "turn" }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
-- https_ports = { }; -- Remove this line to prevent listening on port 5284

-- https://ssl-config.mozilla.org/#server=haproxy&version=2.1&config=intermediate&openssl=1.1.0g&guideline=5.4
ssl = {
    protocol = "tlsv1_2+";
    ciphers = "ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384"
}

unlimited_jids = {
    "focus@auth.mydomain",
    "jvb@auth.mydomain"
}

VirtualHost "mydomain"
    -- enabled = false -- Remove this line to enable this host
    authentication = "anonymous"
    -- Properties below are modified by jitsi-meet-tokens package config
    -- and authentication above is switched to "token"
    -- app_id="wirtualus"
    -- app_secret="4d965142"
    -- allow_empty_token = false;
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.
    ssl = {
        key = "/etc/prosody/certs/mydomain.key";
        certificate = "/etc/prosody/certs/mydomain.crt";
    }
    av_moderation_component = "avmoderation.mydomain"
    speakerstats_component = "speakerstats.mydomain"
    conference_duration_component = "conferenceduration.mydomain"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "external_services";
        "conference_duration";
        "muc_lobby_rooms";
        "muc_breakout_rooms";
        "av_moderation";
    }

    c2s_require_encryption = false
    lobby_muc = "lobby.mydomain"
    breakout_rooms_muc = "breakout.mydomain"
    main_muc = "conference.mydomain"
    -- muc_lobby_whitelist = { "recorder.mydomain" } -- Here we can whitelist jibri to enter lobby enabled rooms

--VirtualHost "guest.mydomain"
--    authentication = "token"
--    c2s_require_encryption = false

Component "conference.mydomain" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        "polls";
        --"token_verification";
	--"token_affiliation";
        "muc_rate_limit";
    }

    admins = { "focus@auth.mydomain" }
    muc_room_locking = false
    muc_room_default_public_jids = true


Component "breakout.mydomain" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        --"token_verification";
        "muc_rate_limit";
    }

    admins = { "focus@auth.mydomain" }
    muc_room_locking = false
    muc_room_default_public_jids = true

-- internal muc component
Component "internal.auth.mydomain" "muc"
    storage = "memory"
    modules_enabled = {
        "ping";
    }
    admins = { "focus@auth.mydomain", "jvb@auth.mydomain" }
    muc_room_locking = false
    muc_room_default_public_jids = true

VirtualHost "auth.mydomain"
    ssl = {
        key = "/etc/prosody/certs/auth.mydomain.key";
        certificate = "/etc/prosody/certs/auth.mydomain.crt";
    }
    modules_enabled = {
        "limits_exception";
    }
    authentication = "internal_hashed"

-- Proxy to jicofo's user JID, so that it doesn't have to register as a component.
Component "focus.mydomain" "client_proxy"
    target_address = "focus@auth.mydomain"

Component "speakerstats.mydomain" "speakerstats_component"
    muc_component = "conference.mydomain"

Component "conferenceduration.mydomain" "conference_duration_component"
    muc_component = "conference.mydomain"

Component "avmoderation.mydomain" "av_moderation_component"
    muc_component = "conference.mydomain"

Component "lobby.mydomain" "muc"
    storage = "memory"
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_default_public_jids = true
    modules_enabled = {
        "muc_rate_limit";
    }

VirtualHost "jigasi.meet.jitsi"
    enabled = false -- Jitsi meet components customers remove this line
    modules_enabled = {
      "ping";
      "bosh";
    }
    authentication = "token"
    app_id = "jitsi";
    asap_key_server = "https://jaas-public-keys.jitsi.net/jitsi-components/prod-8x8"
    asap_accepted_issuers = { "jaas-components" }
    asap_accepted_audiences = { "jigasi.mydomain" }






when i tried pointing my apache config file to usr/share/jitsi-meet i don’t have this issue regarding moderators but when i point it to my self hosted jitsi code, i do come across this unwanted behaviour.
I originally cloned the repository around December 2021 - January 2022, I don’t know if this was an issue back than but that is the most info I currently can salvage regarding this issue and my setup

So things work as expected if you use the jitsi-meet version that corresponds with the other components, but only breaks if you use your own version which you forked a long time ago?

Sounds like the problem is in your code then? Although it’s a bit strange for an incompatibility in the front-end client to unexpectedly make everyone moderator unless you included explicit calls to promote others.

Not sure how else I can help in afraid. All I can say is it is generally advisable to always use client that matches backend components. Which means if you fork then code then you will need to upgrade and merge your changes to stay compatible.

I have tried to clone the repository and git checkout to the following commits (which was the commit I originally installed) with the same conf files i sent earlier and I still have this issue where everyone has moderator rights. which leads me to believe that something in this commit is the sources of this behaviour and I don’t exactly know what. GitHub - jitsi/jitsi-meet at stable/jitsi-meet_6865 GitHub - jitsi/lib-jitsi-meet at v1484.0.0+6d5ca18b

at this point I was able to solve my issue by implementing a new iframe api command that runs revokeOwner method in the lib-jits-meet api after any unwanted participants have their roles changed to moderator I use the participantRoleChanged event to determine when to run api.executeCommand(‘revokeModerator’, participant_id); which I accomplished by modifying the files in jitsi-meet/react/features/base/participants/ , jitsi-meet/modules/API/API.js and jitsi-meet/modules/API/external/external_api.js