Difficulty Connecting to Jitsi Meet

I am unable to start or join a meeting. I am on a desktop PC using Windows 10 and Google Chrome. I have allowed access to my camera and microphone but when I try to join a meeting I get a grey screen with a light grey window saying ‘Jitsi Meet needs to use your microphone and camera. Select Allow when your browser asks for permissions’. Nothing is active and it goes no further. Any suggestions?

Try going into Chrome settings>privacy and security>site settings>microphone and camera and see if meet.jitsi is listed, for both and delete both microphone and camera there. Then start again and see if now you get the ‘allow’ button show up. I’ve done this previously with users and it worked. Good luck.

Thanks, Michael, for your reply. I tried that and it did prompt me with an ‘Allow’ pop up which I selected, but then it left me in the same place.

Regards,

Nev

There are Windows privacy settings to allow chrome to use mic and camera.