Dialout Feature Not Populating on Jitsi Meet

I have JitsiMeet, Jigasi, and Opensips all hosted on the same GCP instance.

I JitsiMeet works as intended and Jigasi has a registered endpoint to the Opensips instance. My problem is I cannot get the telephone option to dial out on my hosted JitsiMeet.

Does this have something to do with XMPP settings? I’ve added the ‘dialpad’ to the Toolbar Buttons, but no luck.

Any pointers in the right direction would be much appreciated as per the documentation this feature should just be plug and play.


Does your jigasi logs in the brewery on prosody and have you configured jicofo to look into that room for jigasi, as described in the readme?

Yes. Jigasi successfully joins the brewery room:

2023-04-09 23:43:21.894 INFO: [25] CallControlMucActivator.joinCommonRoom#321: Joined call control room: JigasiBrewery@internal.auth.meet.dialsource.com pps:ProtocolProviderServiceJabberImpl(Jabber:jigasi@internal.auth.meet.dialsource.com), id:acc-xmpp-1 nickname:jitsi-2cqpi7j sessionId:null

Here is the bridge and jigasi section of my jicofo config - which is OOB I haven’t touched it.

  bridge: {
    brewery-jid: "JvbBrewery@internal.auth.meet.dialsource.com"
  jigasi: {
    brewery-jid: "JigasiBrewery@internal.auth.meet.dialsource.com"

It appears to also properly connect to the bridge:

Jicofo 2023-04-10 00:22:53.705 INFO: [41] BridgeSelector.addJvbAddress#92: Added new videobridge: Bridge[jid=jvbbrewery@internal.auth.meet.dialsource.com/2c7f263e-68f9-4f6a-ba40-327916077a4a, version=2.2.79-gf6426ea0, relayId=null, region=null, stress=0.00]

I restart all services and when i jump into a conference room, there is no option to dial. If I’m missing something in the readme, let me know. TIA for any help!

You need to show the participants pane, then there is the invite someone button and in that dialog you can enter the number and dial it.

Correct. I can navigate there, but per my screenshot attached - I have no option to dial or input anything. Just the ability to copy the link and use email:

Screenshot 2023-04-09 at 11.05.59 PM

I can share any other logs that might be helpful. Thanks!

Did you do this part?

And make sure you are a moderator in the meeting.

Isn’t that what this is in sip-communicator.properties?


That has to be added somewhere else? I didn’t think an API request was needed for this to work.

When you restart your jigasi do you see in jicofo logs that it discovers it? Are you moderator in the room when trying to dial out?

Yes. I am the moderator. I set up authentication with a secure domain so by default I believe everyone is.

Hi all. I found the solution!

Jicofo wasn’t properly setting up because nginx was using port 8888 for my opensips control panel. I fixed this port issue and jicofo was able to properly start up and now allowed me to gain true moderator controls.

Thanks again to everyone who assisted!