Dial-in with more than three participants

Hi!

I seem to have a variant of the common “more than two participants don’t work”-problem, but with a twist.

I have installed a Jitsi-instance on a Ubuntu-machine according to the documentation and also set up a SIP-account for Jigasi.

The following scenarios have been observed:

  • Web-user A creates a meeting
    User B dials in – quality is perfect
    User C dials in – user A can hear both, B and C hear cracking sounds

  • Web-user A creates a meeting
    User B connects via web – quality is perfect
    User C dials in – user A and B can hear everyone, C hears only cracking sounds

In summary: it seems that the return paths of all dial-in participants have a problem as soon as there are more than two participants in a meeting.

I have tried turning the translator (USE_TRANSLATOR_IN_CONFERENCE) on or off, but to no avail.

Best

The sounds like you are doing multi streaming (translator is enabled) on a sip service that do not support that.
Does your sip service support translator mode?

Thanks for getting back to me so quickly!
We a re using a (more or less) default Kamailio + rtpengine installation. I presume, that what Jigasi calls a “translator” is the “transcoder” there. In this case – yes, our rtpengine does support transcoding and yes, it supports both opus and the phone’s codec (PCMA).
I have, however, also tired the set-up with the translator disabled, and it didn’t work either…

Nope translator, is the mode where jigasi just forwards any audio rtp stream it receives to the sip side. For a 3 way call where the third participant is jigasi it will forward two audio streams, two different ssrcs to the sip side, and the sip side needs to do the mixing.

This explains why it doesn’t work with the translator enabled.
When the translator is disabled, Jigasi – or jvb – does the mixing. Any idea why it still doesn’t work?

Jigasi does the mixing. maybe share your jigasi config, how is the cpu on the jigasi machine?