DevToolsActivePort file doesn't exist in Jibri

Hi all im facing this issue when I click the record button the recording fails after about a minute. it does not record anything either.

I checked the JIBRI logs and I got the following

Very grateful if anyone can help me here.

Starting ChromeDriver 96.0.4664.45 (76e4c1bb2ab4671b8beba3444e61c0f17584b2fc-refs/branch-heads/4664@{#947}) on port 16444
Only local connections are allowed.
Please see ChromeDriver - WebDriver for Chrome - Security Considerations for suggestions on keeping ChromeDriver safe.
ChromeDriver was started successfully.
Jibri 2022-06-08 15:16:31.658 FINE: [18] WebhookClient$updateStatus$1.invokeSuspend#107: Updating 0 subscribers of status
Jibri 2022-06-08 15:17:30.043 SEVERE: [68] XmppApi.handleStartJibriIq#294: Error starting Jibri service
org.openqa.selenium.WebDriverException: unknown error: DevToolsActivePort file doesn’t exist
(Driver info: chromedriver=96.0.4664.45 (76e4c1bb2ab4671b8beba3444e61c0f17584b2fc-refs/branch-heads/4664@{#947}),platform=Linux 4.18.0-240.el8.x86_64 x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 60.05 seconds
Build info: version: ‘unknown’, revision: ‘unknown’, time: ‘unknown’
System info: host: ‘jitsi-6cf6f5dc5-klrjf’, ip: ‘172.17.0.5’, os.name: ‘Linux’, os.arch: ‘amd64’, os.version: ‘4.18.0-240.el8.x86_64’, java.version: ‘11.0.14’

You keep creating threads on the same line of issues (Jibri… recording…) with no feedback on whether suggestions and attempts to help in your previous threads made any difference. All these ‘issues’ are related and should stay in the same thread. No need to create a new thread, especially when you ghost on attempts by people to help on previous threads. And please do not tag people in your requests for help unless they’re already helping with that issue in that thread.

@Freddie noted my apologies. I opened a new thread cause this was different issue coming from chrome. and I have marked the solutions in my previous threads now.

You might want to go through this tutorial to see if it’d help you resolve the issues you’re experiencing with Jibri:

Thank you very much. I will follow it

managed to fix by adding the following to the jibri.conf

ffmpeg {
  resolution = "640x360"
  // The audio source that will be used to capture audio on Linux
  audio-source = "alsa"
  // The audio device that will be used to capture audio on Linux
  audio-device = "plug:bsnoop"
  }
chrome {
  // The flags which will be passed to chromium when launching
 flags = [
    "--use-fake-ui-for-media-stream",
    "--start-maximized",
    "--kiosk",
    "--enabled",
    "--autoplay-policy=no-user-gesture-required",
    "--no-sandbox",
    "--disable-dev-shm-usage",
    "--headless"
    ]
  }

However it takes me to another error related to the sound card

What do you get when you run:

lsmod | grep snd_aloop

I get the same output inside the server as well as inside the container

snd_aloop 32768 7
snd_pcm 118784 1 snd_aloop
snd_timer 40960 3 snd_seq,snd_aloop,snd_pcm
snd 94208 19 snd_seq,snd_seq_device,snd_timer,snd_aloop,snd_pcm

IIRC this flag causes problems

@Freddie @emrah Thank you for the support guys… I managed to fix it by allowing privilege=true for the container.

      securityContext:
        capabilities:
          add:
            - NET_BIND_SERVICE
            - SYS_ADMIN
        privileged: true

thank you… it did work for my chrome issue though