Desktop Sharing Frame Rate config override not working on meet.jit.si (fps)

Hi there,

I’m trying to get 30fps when sharing the desktop.
So I override the desktopSharingFrameRate when loading Jitsi Meet in an iframe via the external API.

configOverwrite: {
    desktopSharingFrameRate: {
        min: 30,
        max: 30
    },
},

But Jitsi Meet keeps reporting 5fps, both locally and on the remote end.
The actual video element does seem to display in 30fps, but only locally.
The remote end displays in 5fps.

Please see if you can reproduce this using this fiddle:
https://jsfiddle.net/9nxaouwm/embedded/result/
Open two times and then share desktop in one of them.

For this you need a custom deployment and to change: https://github.com/jitsi/lib-jitsi-meet/blob/master/modules/RTC/RTCUtils.js#L70

Edit: on the other hand your settings should be taken into account here: https://github.com/jitsi/lib-jitsi-meet/blob/master/modules/RTC/RTCUtils.js#L483

I think I was able to get 30fps working with lib-jitsi-meet, connecting to the meet.jit.si server. But I ran into other issues when doing that, so right now I’m trying to get 30fps screen sharing working again with the external api…

According to the API docs it should work:

  • configOverwrite : (optional) JS object with overrides for options defined in config.js.

config.js contains the following:

    // Optional desktop sharing frame rate options. Default value: min:5, max:5.
    // desktopSharingFrameRate: {
    //     min: 5,
    //     max: 5
    // },

So overriding that setting should change the fps, but seems like it’s not completely working.
Can you reproduce the issue?

Yes, I can reproduce it, it seems that setting it like this doesn’t affect the result.

Sorry I don’t understand what you mean. Is there already a working way to override the fps when using the external api? Or is it a bug that needs to be fixed?

Settings passed through the iframe API are correct, but it seems those are not taken into account the way we set it to the track. It needs more work and testing to fix it, any PR is welcome.

Seems applying constraints to the track doesn’t work https://github.com/jitsi/lib-jitsi-meet/blob/master/modules/RTC/RTCUtils.js#L1252

Thanks for tracking down the issue! It’s a bit over my head :slight_smile:

Have you found a fix? I’m having the same problem.

I also still have this problem, and made an issue for it on GitHub. I don’t have a real solution, but perhaps one of these two workaround are helpful to you for now.

  1. Capture your desktop with OBS Studio and present it as a virtual webcam. You can then select this virtual webcam in Jitsi Meet and not use the desktop capture in Jitsi Meet at all. It’s Windows only and you need to install additional software.
  2. Use the Jitsi Meet presenter mode (start sharing your desktop and then unmute your webcam). You now have a 30 fps stream of your desktop, but with your webcam in it too…

Hopefully this gets fixed in Jitsi Meet soon :slight_smile:

For me it seems like a chrome webrtc bug. The screen sharing has way more fps in Firefox.

Hello team, am new on this…

First of all thank you very much for this excellent product!

I’m trying to put together a Zoom-like conference system with my friends for a non-profit org, to make conf calls and share videos and images, screen sharing.

Jitsi is without a doubt a tough contender (we love it!), but I find that by sharing the screen the video very well only when it is P2P, but by adding more users the video does not come out smooth, it comes out choppy.
The server is very good, the internet connection is very good, and I am testing it with different browsers.
I tried changing the fps in config.js but I still can’t get it to work properly.

Any clue?

Thanks in advance (and sorry English is not my native language)

Danny