Dependency errors when doing a fresh install in Ubuntu 20.04

Hi. Today, there are dependency errors when doing a fresh install in Ubuntu 20.04. The following errors are:

The following packages have unmet dependencies:
jitsi-meet : Depends: jicofo (= 1.0-756-1) but it is not going to be installed
Depends: jitsi-meet-prosody (= 1.0.5056-1) but it is not going to be installed
Recommends: jitsi-meet-turnserver (= 1.0.5056-1) but it is not going to be installed or
apache2 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Kind regards

Are you installing from unstable? If so, there was a fix pushed out earlier:

No, I am trying to install stable. If I use the unstable repo, here is the error:

The following packages have unmet dependencies:
jitsi-meet : Depends: jicofo (= 1.0-784-1) but it is not going to be installed
Depends: jitsi-meet-prosody (= 1.0.5204-1) but it is not going to be installed
Recommends: jitsi-meet-turnserver (= 1.0.5204-1) but it is not going to be installed or
apache2 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Stable should be fine. How are you installing? What guide are you using?

I always use this guide: Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook
However, I’m sure the problem is pebkac as the install is now working fine. Thanks for the reply and I apologize for the noise.

Glad to hear! :+1:t5: