I recently installed updates on my Debian 10 server but am unable to update jitsi-meet due to a dependency issue with jitsi-meet-prosody. Attempting to update jitsi-meet by itself yields the following diagnostic:
apt-get install jitsi-meet
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.6854-1) but 1.0.6644-1 is to be installed
E: Unable to correct problems, you have held broken packages.
However, according to “apt-get list --installed | grep jitsi-meet”, jitsi-meet-prosody is upgradeable to the desired version. Here are the results of running that command:
jitsi-meet-prosody/stable,now 1.0.6644-1 all [installed,upgradable to: 1.0.6854-1]
jitsi-meet-turnserver/stable,now 1.0.6854-1 all [installed,auto-removable]
jitsi-meet-web-config/stable,now 1.0.6644-1 all [installed,upgradable to: 1.0.6854-1]
jitsi-meet-web/stable,now 1.0.6644-1 all [installed,upgradable to: 1.0.6854-1]
jitsi-meet/stable,now 2.0.7882-1 all [installed,upgradable to: 2.0.8138-1]
Fortunately the installed jitsi-meet is still working fine. How to fix this problem and update to the latest?
The self-hosting documentation have been updated, you need to add a separate repo for prosody now:
You also most likely need to do this: Jitsi Meet 2.0.8044 update dependency issues? - #24 by damencho
Thank! I added the prosody repository per the new documentation. However “apt-get update” complains (errors below). I also had to use the “–allow-insecure-repositories” option with apt-get to update the repo. Although I added the key according to the instructions, apt-get insisted the repository was unsigned.
W: The repository 'http://packages.prosody.im/debian buster Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://packages.prosody.im/debian/dists/buster/main/binary-amd64/Packages 410 Gone [IP: 18.104.22.168 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Looking at the “Jitsi Meet 2.0.8044 update dependency issues?” post and thread, it looks like this update is a bit of a minefield!
Is the gpg key present in
It seems that
buster is not a distro supported by
IMO the best solution is to upgrade distro
Maybe just add the “bullseye” version of the Prosody repo. Use Debian 10 Buster for the OS and just the Bullseye version from official Prosody. There should be no conflicts, or at least nothing critical.
deb http://packages.prosody.im/debian buster main
deb http://packages.prosody.im/debian bullseye main
or you can use “stable”, as Bullseye is the current stable.
No wonder there are problems if Debian 10 is not officially supported for the new version of prosody. The version of Jitsi I have now is actually working fine for my purposes. I’m going to be upgrading the OS to Debian 11 when I have time anyway so the Jitsi upgrade can wait. (I’d rather not get further into dependency hell.) Thanks!