Default timeout for authenticated users

#1

HI there,

I installed Jitsi Meet on a Ubuntu 16.4 LTS and applied the secured domain configuration:

https://github.com/jitsi/jicofo#secure-domain

everything looks perfect so far.

Users are authenticated to start the meetings, while guests will wait until the meeting starts by authenticated users and then they can join.

The only thing that I could not figure out (even after searching this forum and google) is the session’s timeout for authenticated users. Once a user logs in, he is always logged in, I know there is a logout button, but it would be great if the session’s timeout is set to 2-3 minutes from the time the meeting is over.

So, is this configurable?

Thanks for all the efforts done so far with this great solution.

0 Likes

#2

IIRC the login information is saved in local / session storage, that’s how it’s remembered.

0 Likes

#3

Thanks for the quick reply, but how do I set this up. Is in the Prosody, Jicofo configuration files?

0 Likes

#4

In jicofo there is an auto login option which you can disable and no caching will be taken into account, and will ask for user/pass every time

0 Likes

#5

See these options you can set in sip-communicator.properties: https://github.com/jitsi/jicofo/blob/20a106a17accaaf664ee812962df966d7a9c4fcb/src/main/java/org/jitsi/jicofo/auth/AuthBundleActivator.java#L60

0 Likes

#6

That is great.

I just updated the sip-communicator.properties under /etc/jitsi/jicofo and added the following setting:

org.jitsi.jicofo.auth.DISABLE_AUTOLOGIN_PNAME=true

Restarted all the services.

Unfortunately, nothing changed, I am still logged in forever!

Am I missing something?

0 Likes

#7

You need to set org.jitsi.jicofo.auth.DISABLE_AUTOLOGIN=true

0 Likes

#8

Worked like a charm, thanks for the help :smiley:

0 Likes