Default server URL not changing

I’ve changed the default server url in the default settings but whenever i start a room its using meet.jit.si as server. How can i change this?