Debian packages: Is APT line for "testing" deprecated?

(This is a question for the Jitsi developers, but I’m asking it here because I believe it relates to “Install”)

The following apt line:

deb https://download.jitsi.org testing/

seems not to work properly anymore. This is the error message:

E: The repository 'https://download.jitsi.org testing/ Release' does not have a Release file.

At the same time, the Downloads page:

shows only “stable” and “nightly” (unstable).

So: Does this mean that testing is not expected to work anymore? If yes, does it mean that packages will directly transition from unstable to stable when they are mature enough?

Thanks.

I will take a look on Monday to bring back testing.

We were shuffling things around download.jitsi.org last week.

I tried again after reading the message below and now testing works again. (Maybe Cloudflare was the reason for testing not to work?)

It’s possible that we also hadn’t properly moved this repo when we changed servers, so it could have been something else we fixed in the meantime since you last checked. I’m not 100% sure how cloudflare might’ve broken testing but not unstable/stable for you, but either way I’m glad it’s all working for you now.

I fixed it. Sorry for not saying earlier.