Debian package issue

Please help me in resolving this issue.

When I try to build the .deb packages I get this error.

root@e8dd6b0dd04b:/jitsi-meet# dpkg-buildpackage -A -rfakeroot -us -uc -tc
dpkg-buildpackage: warning: using a gain-root-command while being root
dpkg-buildpackage: source package jitsi-meet-web
dpkg-buildpackage: source version 1.0.1-1
dpkg-buildpackage: source distribution unstable
dpkg-buildpackage: source changed by Damian Minkov
dpkg-source --before-build jitsi-meet
fakeroot debian/rules clean
dh clean
dh: Sorry, but 10 is the highest compatibility level supported by this debhelper.
make: *** [clean] Error 25
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2

Here is my debhelper and dh autoreconf installed version:
Installed: 9.20131227ubuntu1
Candidate: 9.20131227ubuntu1
Version table:
*** 9.20131227ubuntu1 0
500 trusty/main amd64 Packages
100 /var/lib/dpkg/status
Installed: 9
Candidate: 9
Version table:
*** 9 0
500 trusty/main amd64 Packages
100 /var/lib/dpkg/status

Here is my current ubuntu os version:
“Ubuntu 14.04.6 LTS”

You need to update your system to something more recent.

Please note that this is also a subtle packaging bug. There is a rule in Debian saying “if the build-dependencies are met, the package must build”, but this is currently not the case.

The Build-Depends field says debhelper (>= 8.0.0) but the compat level in debian/compat says 12. So, the build-dependency should be like this:

Build-Depends: debhelper-compat (= 12)

(That’s the modern way, see debhelper(7) for details).

After this change, anybody trying to build using an old environment will receive an error message from dpkg-buildpackage itself:

dpkg-checkbuilddeps: error: Unmet build dependencies: debhelper-compat (= 12)
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
1 Like

Thanks, a PR is welcome.

Thanks @damencho. It works after upgrading to Ubuntu 18.04.