Debian package building fails on Ubuntu 20.04

Hi,
I have been trying to build a debian package after making some changes to the UI on my jitsi-meet installation. Here is what I am doing:

  1. Cloned jitsi-meet project.
  2. Made some UI changes to the welcome page.
  3. Followed the instructions on https://jitsi.github.io/handbook/docs/dev-guide/dev-guide-web to build my .deb package

I ran the below commands from the my jitsi-meet folder:

npm install
make
dpkg-buildpackage -A -rfakeroot -us -uc -tc

I see the below error when running dpkg-buildpackage command above

/home/ubuntu/meeting/debian/jitsi-meet-web-config.dirs: 1: etc/jitsi/meet/: not found
dh_installdirs: warning: debian/jitsi-meet-web-config.dirs is marked executable but does not appear to
an executable config.
dh_installdirs: warning:
dh_installdirs: warning: If debian/jitsi-meet-web-config.dirs is intended to be an executable config file,
please ensure it can
dh_installdirs: warning: be run as a stand-alone script/program (e.g. “./debian/jitsi-meet-web-
config.dirs”)
dh_installdirs: warning: Otherwise, please remove the executable bit from the file (e.g. chmod -x
“debian/jitsi-meet-web-config.dirs”)
dh_installdirs: warning:
dh_installdirs: warning: Please see “Executable debhelper config files” in debhelper(7) for more
information.
dh_installdirs: warning:
dh_installdirs: error: debian/jitsi-meet-web-config.dirs (executable config) returned exit code 127
make: *** [debian/rules:10: binary-indep] Error 255
dpkg-buildpackage: error: fakeroot debian/rules binary-indep subprocess returned exit status 2

Any help would be great.

Regards,
Neehal

This is now resolved. I compared my project files to the one’s in the Jitsi-meet project on github. Noticed that all files under our project folder had execute(-rwxr-x- -x) access permission, whereas the Jitsi project files didn’t.
I then performed chmod 644 on all files, and tried packaging again. The issue was gone.

find . -type f -name “*.*” -exec chmod 644 {} +

1 Like