Debian Firefox 78 ESR not working, blank window

A few weeks ago I noticed that I couldn’t connect to meet.jit.si but it was working OK on other public Jitsi Meet servers

Now I found that most servers have the same problem: when I connect, the window is blank.

I’m using Firefox 78 ESR on Debian, there are some other reports of issues too, for example, in this thread but I’m not sure if that is the same issue.

There is no error in the window

I looked in the JavaScript console

From meet.jit.si there is no error in the JavaScript console.

Using one of the other public Jitsi Meet servers I saw this in the JavaScript console:

2021-06-08TxZ [modules/browser/BrowserCapabilities.js] This appears to be firefox, ver: 78.0 lib-jitsi-meet.min.js:10:20614

Source map error: Error: WebAssembly is not defined
Resource URL: https://meet.example.org/libs/lib-jitsi-meet.min.js?v=5052
Source Map URL: lib-jitsi-meet.min.map

That server was working last week but it is not working this week.

Isn’t that a little old?

No, Firefox ESR 78.11.0 is the latest ESR version, released 1 June 2021

Debian distributes Firefox ESR, not the bleeding edge releases

Enable javascript.options.wasm and try again.

On my system, javascript.options.wasm has a default value true

On my system, javascript.options.wasm_verbose has a default value false

is there anything else I can try?

are there any other logs I can enable to get more information about the problem?

I’ve tried it on two different computers, one of them is x86_64 and the other is a ppc64le workstation (the open hardware Talos II)

The same version of Firefox ESR on both computers

It is working on the x86_64 system, the problem only occurs on the system with ppc64le architecture.

This problem only started some time between 15-29 March, Jitsi Meet was working fine at the beginning of the year. Do you know what changed in that period?

Hum, maybe the virtual backgrounds … the problem started after jitsi-meet upgrade?

These are problems I’ve had using the public instance of Jitsi Meet at meet.jit.si - was it upgraded or was the configuration changed in March?

Yeah, there was a release in that period and my notes point to https://github.com/jitsi/jitsi-meet/compare/4685...4848
So something in there … we need to figure out what was it …

I would guess the blur effect … is there an easy way to reproduce this without having a machine running on ppc64le architecture?

If you download Firefox ESR and disable wasm in the config, would that be an equivalent test?

I notice that even though the browser does not support WASM, the settings show that it is enabled.

Does anybody know when WASM will be available in Firefox on non-x86 platforms? Is there a bug tracking this at Mozilla?

@damencho I worked on fixing this with @Calinteodor and found some solutions. [Opened PR with fixes](https://github.com/jitsi/jitsi-meet/pull/9410)
A short PR summary:

  • Check if the WebAssembly feature is supported or enabled by/in the browser.
  • Conditional import of wasm-check package is done to prevent the browser from crashing when the user opens the app.
2 Likes

Thanks for this, I tested it today using meet.jit.si and it is working for me.

Some other sites running Jitsi Meet haven’t updated their code yet, they still have this bug until they update.

Thanks for the fast solution.

2 Likes