Debian buster JVB2 HAProxy

Dear All,

There are lots of reports describing that on Debian buster, neither upgrades nor fresh installs with jvb2-Packages do work. These are my findings in this respect:

I run a fully working Debian buster install of the pre-jvb2-Version. Last week I had to revert and disable updates to keep this running. My instance is behind NAT (with adequate configuration for NAT) and behind HAProxy with ssl offloading. The HAProxy backend points to port 443 without certificate checks, as I found it difficult to modify jitsi meet to work without ssl.

When upgrading, I got the following error:

AbstractJettyBundleActivator.doStart#222: Failed to initialize and/or start a new Jetty HTTP(S) server instance.

On a fresh install, I noticed that I needed to switch to port 4444. Port 443 does show the welcome screen locally, but HAProxy will not recognize it - with or without health check.

Then, one can initiate a conference but as soon as the second participant joins, the first participant will be cicked out. The logs show:

org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.

systemctl status does show jvb running, however.

I do find the substantial changes in configuration files surprising. For example, /etc/jitsi/jicofo/sip-communicator.properties

used to contain:
org.jitsi.jicofo.auth.URL=XMPP:[external url]

it does now contain:
org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.ok

Adding the old line or replacing the new line by the old line does not help.

Can anyone provide an insight on how to proceed, please?

Will it still be possible to run the jvb2-Version behind HAProxy with SSL offloading?

Regards,

Michael Schefczyk

Dear All,

I did mostly solve my issues. I found it impossible to upgrade, so I did a fresh install.

For the fresh install, as indicated elsewhere, it is critical to install nginx first. I have an ansible script which includes installing jtisi-meet. However, jitsi-meet install fails as it does require manual intervention. I did change to installing everything else first and that did seem to make a difference.

The main credit for an install behind HAProxy goes here: Nginx, coturn & port 443

This order did work in my case:

  • install all prerequisites including nginx (!) first
  • apt install jitsi-meet (-> external url, self signed certificate)
  • apt purge jitsi-meet-turnserver && apt autoremove && reboot
  • (no change to /etc/prosody/prosody.cfg.lua - as it has more than just three lines of includes)
  • advanced configuration settings done (https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md)

Regards,

Michael Schefczyk