Customize / personalize "ADD A Jitsi Meeting" button for calendar

Hi Jitsi Team,
After we successfuled to install the Calendar integration on our Jitsi Meet app, when we add a new event, we always have the button “ADD A Jitsi Meeting” on the GMail Calendar.
We would like to don’t have it (as we are not using the “link” function for the calendar. We only need to show the events).
We tried to find where is that button, but no luck.

Could you tell us where is the code to change, to don’t have that button inserted on our Gmail Calendar ? (don’t have that function of insert a Jitsi Meet link by default)

Thanks for your help and support !

This is the calendar integration part of jidesha, the chrome extension.

Thanks! Found it on Jidesha Master.
But how our users can use it? There is nothing to ask them to install that “calendar” extension for chrome. We only have the extension code for the sharing screen option, but not for calendar one. Or maybe i missed (again :smiley: ) something on my configuration?

I already uploaded the extension for the sharing screen and it’s working, but seems like calendar extension is another extension (right?) that need also to be uploaded on our extension chrome developper account, so with a new hash code that we don’t know where to insert in our jitsi meet installation, in order to use it.

On the documentation file (readme) there is only explanation for the sharing screen extension.

But you have one extension installed for deployment? That has the calendar part that is from jidesha, do you see the button if you disable that extension?

I did my own application with the master git of Jitsi (last version) in opt/jitsi-meet.
npm install and make as usual.
But impossible to find the parameter for the calendar jidesha extension. I only have a parameter for the jidesha chrome / sharing screen extension.
So i always have the “Jitsi” blue button on my gmail agenda / calendar, and not the button I want to have (with custom name etc…).
Where I have to install the calendar extension ? If i install it on Chrome extenson, it gave me a new hash for the extension that i don’t know where to set it on jitsi-meet.
Or do I have to have chrome AND calendar (from jidesha master, where there is 2 directory : chrome and calendar) on the same extension ? If yes, how we can upload both in same extension ?

If i deactivates my jidesha screen sharing extension, i still have the same problem : blue button with ADD a Jitsi Meeting on my event.
So seems like we use the “jidesha calendar” extension of Jitsi Meet, but we don’t know where to set our own extension in config / parameters.
Or maybe as I said before, we need to have “chrome” and “calendar” concatened in same extension for Chrome ?

I only see these parameters in config :
chromeExtensionId: ‘kglhbbefdnlheedjiejgomgmfplipfeb’, // Id of desktop streamer Chrome extension
//new desktop sharing settings
desktopSharingChromeExtId: ‘kglhbbefdnlheedjiejgomgmfplipfeb’, // Id of desktop streamer Chrome extension

Only about “screen sharing” but not “calendar” extension.
(this was takes from your Jitsi Meet app. We have our own extension hash for our jidesha extension)

If you have uploaded jidesha to google chrome store, you need to modify it to add the calendar integration.
Modify it as you like, then:

cd jidesha
cd calendar

Go in target folder that was created and grab that, zip it and upload that one as an extension, the same way you already did. And when you install that extension from the store in your chrome you will have your button next to Add Jitsi Meeting button that comes from the extension you installed for
There is nothing to configure on your deployment for that calendar integration.

Many thanks Damencho! Will try all of this and let you know :slight_smile:
Thanks again for your great support

Ok so I did it, and I have now my button.But the button of “Jitsi Meet” stay…
I would like to just have my button, and not “2 buttons” (people can use the both so this is not so good…).
How can I do to only have my button and not the Jitsi Meeting button?
I have my own Jitsi Meet application, made with make on my server. So I guess I can only use my extensions, and not the Jitsi Meet extension ?
Thanks for your help!

Oooh god… my mistakes!! I had the Jitsi Meeting extension on my Google Chrome… that’s why, simply!
So now it is ALL OK! :slight_smile:
Thank you again for your support! Topic is solved for me !

Oh, just a last question (as I did some tests) : we are in february. When I add an event in March, we don’t see it on the event list on our application.
Seems like we only can see the “current month”. That’s right ?
We will see then our “March” events when we will be on march?

Its most recent ones … Need to check the code to see the time frame…

Ok. Yes I think it only takes few days in the calendar.
Would like to have the full event list on the calendar part of the welcome page, to really see all the upcoming events.
Do you know where to change the code for the date limit, or delete the “limit” to just ask all events that we have on the calendar? (at least, for a year maybe, or minimum 6 months)