Custom Transcription/Translation service (using Microsoft Speech Translation)

Hello everyone!

I’m new here. Don’t mind me if the questions are too basic or abstract. I am trying to configure the jigasi transcription with Microsoft Speech Translation. I have few questions:

  1. Is it possible to configure the service (MC Speech Translation) to work with jigasi transcription?
  2. How would one approach this kind of development (development setup, resource serving)?
  3. Can I only develop on a VPS? Right now I am facing issue with building the project from source because of only 1gb ram droplet from Digital Ocean. I want to know if I can somehow develop it locally and test it then upload the built source code to the hosted server. ( for this one I somehow can get it to build now by stop some of the services)

Best regards,
Panha

Hi and welcome.

Not at the moment.

You can check recently there was a contribution, you can use it as an inspiration Vosk speech recognition transcription service by nshmyrev · Pull Request #294 · jitsi/jigasi · GitHub

You can do a deployment and make jigasi connect to that deployment from your local dev machine, I normally start jigasi in Intellij Idea and it connects to my dev environment.

1 Like

Thank you so much for replying, I’ll definitely check out more from your answer.

Hello again, I’ve tried doing this, but I don’t seem to be able to get it working, can you provide more info for this? I think my jigasi is not connecting to my deployment. jigasi-running-log.txt (13.8 KB)
and my sip-communicator-properties.txt (14.2 KB)

What is the java version you use? I don’t see it even try in the logs. Make sure you run with java8.
And make sure prosody is listening on port 5222 on correct interface and the firewall is not blocking it.

java -version
openjdk version “11.0.10” 2021-01-19
OpenJDK Runtime Environment (build 11.0.10+9-Ubuntu-0ubuntu1.20.04)
OpenJDK 64-Bit Server VM (build 11.0.10+9-Ubuntu-0ubuntu1.20.04, mixed mode, sharing)

netstat -na | grep “5222”
tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:5222 127.0.0.1:34728 ESTABLISHED
tcp 0 0 127.0.0.1:5222 127.0.0.1:34726 ESTABLISHED
tcp6 0 0 :::5222 :::* LISTEN
tcp6 0 0 127.0.0.1:34728 127.0.0.1:5222 ESTABLISHED
tcp6 0 0 127.0.0.1:34726 127.0.0.1:5222 ESTABLISHED

I have also allowed 5222 in the firewall as well. I’m using WSL I wonder if that effects things?

I don’t think jigasi is reading your config file. How are you starting it?

Thanks for sharing this valuable information

krogerfeedback.com

cd jigasi/target/jigasi-linux-x64-1.1-SNAPSHOT ./jigasi.sh --domain=meet.example.com

I followed the build from source in github

Edit: I tried using jigasi quick install in my local pc, and it connects fine to the jitsi deployment.