Custom docker image for jitsi-meet UI shows blank screen

Hi everyone, I’m trying to build a custom image for jitsi-meet UI, the recent docker-compose file always pulls the latest image, and anytime I update it to build from a DockerFile, it shows a blanks screen on my browser after all build process completes.

Maybe check your config.js to make sure you didn’t omit a punctuation mark (typically a comma) somewhere.

please share the steps that you are following to build an image.

DId you change the default image in docker-compose.yaml with your custom image?

I had to delete my existing jitsi/web image, then rebuild the image with this

ARG JITSI_REPO=jitsi
ARG BASE_TAG=latest
FROM ${JITSI_REPO}/base:${BASE_TAG}

ADD https://raw.githubusercontent.com/acmesh-official/acme.sh/2.8.8/acme.sh /opt
COPY rootfs/ /

RUN
apt-dpkg-wrap apt-get update &&
apt-dpkg-wrap apt-get install -y cron nginx-extras jitsi-meet-web socat &&
apt-dpkg-wrap apt-get -d install -y jitsi-meet-web-config &&
dpkg -x /var/cache/apt/archives/jitsi-meet-web-config*.deb /tmp/pkg &&
mv /tmp/pkg/usr/share/jitsi-meet-web-config/config.js /defaults &&
mv /usr/share/jitsi-meet/interface_config.js /defaults &&
rm -f /etc/nginx/conf.d/default.conf &&
apt-cleanup &&
rm -rf /tmp/pkg /var/cache/apt

COPY jitsi-meet/ /usr/share/jitsi-meet
EXPOSE 80 443
VOLUME ["/config", “/usr/share/jitsi-meet/transcripts”]

and it works, I didn’t copy interface_config because of @Freddie comment,
I’ll update and check, thanks

Thanks, I remove interface-config and it works well with the default. I’ll look in to see whats wrong.