Custom app + lib-jitsi-meet --disable-webrtc-encryption

Hi, I’m trying to create a custom app based on https://github.com/fpw23/telimed
I need to disable the webrtc encryption.
When I try there is the following error:

index.js:1 2020-11-27T20:27:52.103Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: Error: Failed to execute 'createDataChannel' on 'RTCPeerConnection': RTCDataChannel creation failed at RTCPeerConnection.e.RTCPeerConnection.createDataChannel (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:25:63902) at A.createDataChannel (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:17:68380) at new l (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:17:17854) at w.initializeBridgeChannel (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:1:104188) at re._setBridgeChannel (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:10:62665) at re._acceptJvbIncomingCall (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:10:61694) at re.onIncomingCall (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:10:61048) at a.emit (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:1:116672) at g.onJingle (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:10:209377) at I.Handler.run (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:1:26547) at https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:1:34985 at Object.forEachChild (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:1:18209) at I.Connection._dataRecv (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:1:34834) at O.Bosh._onRequestStateChange (https://unicorn.ctao6.net/libs/lib-jitsi-meet.min.js?v=139:1:54819) console.<computed> @ index.js:1 index.js:1 2020-11-27T20:27:52.106Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: error: Failed to execute 'createDataChannel' on 'RTCPeerConnection': RTCDataChannel creation failed console.<computed> @ index.js:1 index.js:1 2020-11-27T20:28:02.087Z [modules/xmpp/JingleSessionPC.js] "session-initiate" error null

I see that a message is sent to jicofo:

Jicofo 2020-11-27 17:55:00.817 INFO: [957] org.jitsi.jicofo.ParticipantChannelAllocator.log() Sending session-initiate to: testroomuncr5@muc.meet.jitsi/0331fe63
Jicofo 2020-11-27 17:55:01.591 INFO: [29] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Got session-accept from: testroomuncr5@muc.meet.jitsi/0331fe63
Jicofo 2020-11-27 17:55:01.592 INFO: [29] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Received session-accept from testroomuncr5@muc.meet.jitsi/0331fe63 with accepted sources:Sources{ video: [ssrc=1162742549 ssrc=2473594358 ssrc=2063619042 ssrc=843527582 ssrc=3850059096 ssrc=610776974 ] audio: [ssrc=2061932494 ] }@2034160930
Jicofo 2020-11-27 17:55:01.593 INFO: [29] org.jitsi.protocol.xmpp.AbstractOperationSetJingle.log() Notify add SSRC testroomuncr5@muc.meet.jitsi/dc758568 SID: 16dkb3ljggu1s Sources{ video: [ssrc=1162742549 ssrc=2473594358 ssrc=2063619042 ssrc=843527582 ssrc=3850059096 ssrc=610776974 ] audio: [ssrc=2061932494 ] }@1899408663 source_Groups{ video:[ SourceGroup(FID)[ ssrc=1162742549 ssrc=2473594358 ]SourceGroup(FID)[ ssrc=2063619042 ssrc=3850059096 ]SourceGroup(FID)[ ssrc=843527582 ssrc=610776974 ]SourceGroup(SIM)[ ssrc=1162742549 ssrc=2063619042 ssrc=843527582 ] ] }@1325246329

The problem is that the call does not start and I can’t do my experiments.

I see that jicofo sends back a message, but the browser drops it.

The problem is that with the standard jitsi-meet application with the same videobridge and jicofo works, it does not drop the messages.

do you know why?
I hope in your help

Angelo

The problem was about the use of the same configuration file in
JitsiMeetJS.JitsiConnection and initJitsiConference