Creating a room with a Test/test in the textbox creates strange state because of capital letter

We installed Jitsi on our own servers.
However, If we create a room there with the example /Test/test and you share the URL, people clicking that link see no other participants, e.g. are alone in that room. When doing the same on https://meet.jit.si/ it seems to work. It has to do with the capital T in the name between the / /. Is this something that was recently updated in newest Jitsi Version of something related to a http-sever setting or so?

Help greatly appreciated!

Regards,
Rick

Any response/help would be great appreciated!

Is your deployment configured to use subdomains? That is enabled on meet.jit.si and is by default enabled if you do a clean in install of latest stable packages.

Anything I can do to check that?
On a version of a couple of months ago using meet.domain.com/Test/test gave a 404, but on our current version (of about 1,5 weeks ago), it is just the capital letter problem. So meet.domain.com/Test/test does not work (all person end up in their ‘own’ room, seeing nobody else), while meet.domain.com/test/test and meet.domain.com/test/Test does work (like you expect it to behave).

Thanks!

This is what detects the subdomain https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet/jitsi-meet.example#L91