Create a room to host ... now I cannot get back into it

I created a room on jitsi. We have had at least two successful calls on separate occasions. However, today, the room name doesn’t open. I’ve tried logging in and out. I’ve tried different browsers. I’ve tried clearing the cache. Running out of ideas on how to re-open my own room.

Hi there, and welcome to our community!

When you say it doesn’t open, what do you see?

It just stays on the initial page, where you input the room. When I create some other name, that will open with a new session.

What does it mean by with a new session?

Here I enter the room name and click start meeting and the meeting opens and I join without a problem.

Any other room I enter opens up. The one I used previously will not.

Can you send me the room name as private message to me, so I can check?

Of course …

Don’t see how to create a private message …

Click on my avatar and there is a message button there :slight_smile:

What about email damencho at jitsi org?

Email sent :slight_smile: