Crashing / No connection - local installation

Hey,

we would like to use Jitsi Meet with ca. 1000 Participants

Server:

  • Xeon 12 Core, 128 GB. 10 GB/s -> jvb 1.0, Jicofo prosody
  • Xeon 16 Core, 64 GB, 10 GB/s -> jvb 1.0 (bridge2)
  • Xeon 12 Core, 32 GB, 1 GB/1 -> jvb 1.0 (bridge3)

It works well for small amount of particpants (100) until 5 or 6 per group.

Then, some strange things happens:

  • Some can not connect, they see for a short moment all participant and then “Reconnect…”
  • Sometimes you are connected, but you did not receive any video input or audio from other
  • After a while “bridge XY has failed” in Jicofo log, however the bridge is running

Did not do any ICE configuration since my server provider said, there are not NAT.

jvb.log errors
JVB 2020-03-18 09:45:30.400 SEVERE : [359275] org.jitsi.videobridge.EndpointMessageTransport.log() Failed to send a message over a WebRTC data channel (endpoint=8fd3c428):

JVB 2020-03-18 09:45:30.487 SEVERE : [359279] org.jitsi.videobridge.EndpointMessageTransport.log() Failed to send a message over a WebRTC data channel (endpoint=8fd3c428):

JVB 2020-03-18 09:45:30.549 SEVERE : [359283] org.jitsi.videobridge.EndpointMessageTransport.log() Failed to send a message over a WebRTC data channel (endpoint=8fd3c428):

Jicofo.log errors
Jicofo 2020-03-18 14:11:39.847 SEVERE : [43] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.

Jicofo 2020-03-18 14:11:39.848 SEVERE : [43] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.

Jicofo 2020-03-18 14:11:39.848 SEVERE : [43] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.

JVB 2020-03-18 14:40:39.946 WARN ING: [123] org.jitsi.impl.neomedia.rtp.translator.RTCPFeedbackMessageSender.log() Not sending an FIR because the stream RTP manager is null.

JVB 2020-03-18 14:40:40.246 WARN ING: [123] org.jitsi.impl.neomedia.rtp.translator.RTCPFeedbackMessageSender.log() Not sending an FIR because the stream RTP manager is null.

Thanks for any help, I would also offer to pay for any configuration help.

Some additional information:

prosody.err
/usr/lib/prosody/modules/mod_bosh.lua:483: attempt to index field ‘?’ (a nil value)

Mar 18 07:32:36 general error

stack traceback:

/usr/lib/prosody/modules/mod_bosh.lua:483: in function </usr/lib/prosody/modules/mod_bosh.lua:473>

(tail call): ?

/usr/lib/prosody/util/timer.lua:51: in function ‘?’

/usr/lib/prosody/net/server_select.lua:917: in function </usr/lib/prosody/net/server_select.lua:861>

C: in function ‘xpcall’

/usr/bin/prosody:400: in function ‘loop’

/usr/bin/prosody:431: in main chunk

jvb.log

JVB 2020-03-17 22:27:09.286 SEVERE : [398] org.jitsi.sctp4j.Sctp.log() Init’ing brian’s patched usrsctp

=====>: org_jitsi_sctp4j_Sctp.c calling init

=====>: org_jitsi_sctp4j_Sctp.c about to set SCTP_DEBUG_ALL

=====>: org_jitsi_sctp4j_Sctp.c setting SCTP_DEBUG_ALL

JVB 2020-03-17 22:27:09.378 WARNING: [377] org.jitsi.impl.neomedia.transform.dtls.DatagramTransportImpl.log() Unknown DTLS handshake message type: 98

JVB 2020-03-17 22:27:09.447 INFO: [377] org.jitsi.impl.neomedia.transform.srtp.OpenSSLWrapperLoader.log() jnopenssl successfully loaded

JVB 2020-03-17 22:27:09.590 INFO: [399] org.jitsi.videobridge.SctpConnection.log() SCTP socket accepted on conf_id=33f1b6f64896bad7,content=data,ch_id=fa9c814e7679a9c8,endp_id=d0e0bfbb

JVB 2020-03-17 22:33:45.882 SEVERE : [1302] org.ice4j.socket.MergingDatagramSocket.log() Cannot find socket to remove.