CPU problem with fresh install from docker

Hi everyone,

I installed the jitsi-meet stack depends on docker-compose. The conferences have great works with 30 persons in 1 conference. However, we try to test with 60 persons in 10 conferences, the delay, lag and freeze video was happening.

I need someone to point me what can be wrong with my setup, cuz 60 persons is not the problem with jitsi as its shown HERE

My current setup:

  • Install jitsi-meet with docker-compose
  • Cloudflare domain
  • Nginx for reverse proxy
Server block { listen 80; listen [::]:80;

server_name mydomain.example.com;

location ~ ^/([a-zA-Z0-9=?]+) { rewrite ^/(.*) / break;
}

location / {
if ($request_method = ‘OPTIONS’) {
add_header ‘Access-Control-Allow-Origin’ ‘*’;
add_header ‘Access-Control-Allow-Methods’ ‘GET, POST, OPTIONS’;
add_header ‘Access-Control-Max-Age’ 1728000;
add_header ‘Content-Type’ ‘text/plain; charset=utf-8’;
add_header ‘Content-Length’ 0;
return 204;
}

add_header 'Access-Control-Allow-Origin' '*';
add_header 'Access-Control-Allow-Credentials' 'true';
add_header 'Access-Control-Allow-Methods' 'GET, POST, OPTIONS';
add_header 'Access-Control-Allow-Headers' 'DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type';

proxy_pass http://127.0.0.1:9000;
proxy_set_header X-Forwarded-For $remote_addr;
proxy_set_header Host $http_host;

}

BOSH

location /http-bind {
if ($request_method = ‘OPTIONS’) {
add_header ‘Access-Control-Allow-Origin’ ‘*’;
add_header ‘Access-Control-Allow-Methods’ ‘GET, POST, OPTIONS’;
add_header ‘Access-Control-Max-Age’ 1728000;
add_header ‘Content-Type’ ‘text/plain; charset=utf-8’;
add_header ‘Content-Length’ 0;
return 204;
}

add_header 'Access-Control-Allow-Origin' '*';
add_header 'Access-Control-Allow-Credentials' 'true';
add_header 'Access-Control-Allow-Methods' 'GET, POST, OPTIONS';
add_header 'Access-Control-Allow-Headers' 'DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type';

proxy_pass      http://127.0.0.1:8000/http-bind;
proxy_set_header X-Forwarded-For $remote_addr;
proxy_set_header Host $http_host;
proxy_buffering off;`Preformatted text`
tcp_nodelay on;

}
}

- Install on vmware - vcenter6, ubuntu 18.04.
Detail hardware

RAM: 16GB

CPU:
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 4
On-line CPU(s) list: 0-3
Thread(s) per core: 1
Core(s) per socket: 1
Socket(s): 4
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 85
Model name: Intel® Xeon® Silver 4114 CPU @ 2.20GHz
Stepping: 4
CPU MHz: 2194.843
BogoMIPS: 4389.68
Hypervisor vendor: VMware
Virtualization type: full
L1d cache: 32K
L1i cache: 32K
L2 cache: 1024K
L3 cache: 14080K
NUMA node0 CPU(s): 0-3

I think it can be the problem with jvb cpu usage, when I create another conference with 12 persons, our CPU was 42%.

Has anyone experienced and solved this?
I’m seeing the same issue on both a Strato.de vServer (16 Threads, 60GB RAM, docker-jitsi-meet) as well as on a physical Root Server at Hetzner.de (i7-3770, 16GB RAM). Seeing approx. 70% to 100% of one CPU thread (load average correspondingly ~0.7) loaded in a conference of 7 (5 android phones, 2 iPhones) while only using 20mbit/s.
We’re seeing similar loads in production on the Strato-vServer, at the moment that’s fine-ish, but we have a couple of bigger (20ish people) Webinars coming up.
Also: I’m already running jvb2, that doesn’t seem to be the issue.

Regards,
David