Couple of Newbie Questions


#1

Is development or support of Jitsi still ongoing?

I have installed Jitsi Meet locally in a Vbox VM. I can start a conference on the VM fine. Question is can I join it using my mobile over Wifi on my local network? I installed the mobile Jitsi app but it will not join an existing conference on the VM. All I get on the mobile is a black screen and no indication on the VM conference that I attempted the conference…unless I am not looking in the right place on the server?

Next question is can I use Jitsi for a One to Many broadcast where the “Many” can only view the video and add comments if they desire?

Thanks,

Ray


#2

Have you installed a valid certificate on your deployment? Let’s encrypt was suggested as part of the deployment, but for that you need to have a valid dns entry for your server.

The broadcast case is handled by streaming to youtube. For that you need to deploy jibri https://github.com/jitsi/jibri. You can test this on meet.jit.si.


#3

As I am testing this in my private network, I cannot install a valid cert as “Let’s Encrypt” requires a domain name and not an IP. Is there someway I can get around this? Maybe a self-signed cert?

Thanks,

Ray


#4

You need to install the certificate you use on the web server on the phone which you will use for testing.


#5

I’ve created a self-signed cert on the server. Then I used some of these instructions at https://aboutssl.org/how-to-create-and-import-self-signed-certificate-to-android-device/ to create the mobile cert. Stilll does not work!

Has anyone used the mobile app in their own private network?

Ray


#6

Is the same self-signed certificate used for your webserver that serves jitsi-meet?


#7

Does anyone have a procedure to create the self-signed cert on the server and installing it on the Android phone?

I have created the server self signed cert but not sure about the Android phone part.

Thanks,

Ray


#8

The certificates are created as self-signed when deploying and you just need to get that certificate and install it on your mobile phone.


#9

I have done that. I am still getting a black screen on my Android phone when I try to use the app with the room name from the server?

THanks,

Ray


#10

Here is what I did on the server and Android phone:

Create an auxiliary file “android_options.txt” with this line inside:

basicConstraints=CA:true

Create self-signed certificate using these commands:

openssl genrsa -out priv_and_pub.key 2048

openssl req -new -days 3650 -key priv_and_pub.key -out CA.pem

openssl x509 -req -days 3650 -in CA.pem -signkey priv_and_pub.key -extfile ./android_options.txt -out CA.crt

Now our CA.crt certificate is almost ready.

Convert certificate to DER format:

openssl x509 -inform PEM -outform DER -in CA.crt -out CA.der.crt

Import CA.der.crt:

Put the CA.der.crt onto the sdcard of your Android device (usually to internal one). It should be in root directory.

Go to Settings / Security / Credential storage and select “Install from device storage”.

The .crt file will be detected and you will be prompted to enter a certificate name.

After importing the certificate, you will find it in Settings / Security / Credential storage / Trusted credentials / User.

I verified the cert is in the Trusted Credentials/User folder. Still get a black screen on the Android.


#11

I keep asking this question, but are you using the certificate you created inside the webserver, so the webserver will use that cert to create the https connection?
They need to be the same. I don’t understand why you need to create certificates as they are already created and used by the webserver. That certificate you need to take and install on the android phone, so Android can match and trust the connection.


#12

So does Jitsi-Meet come with certs already out of the box? I didn’t know that. But did you see my explanation about what I did for certs? Does it not make sense?

But yes I am using the cert on the server that I created.

Then I created the mobile cert and exported it to my Android mobile. Is this wrong of me?

Am I not being clear enough?

Ray


#13

You are using some certs that are not used on the server, so it will not work. You need those that are used by the webserver - nginx, apache2 or jetty. The server you use depends on the deployment and whether you had nxing or apache2 installed before installing jitsi-meet.


#14

So I had nginx installed before jitsi.


#15

So you need to open the jitsi-meet nginx config, see where are the certs stored and use that cert to install it on the mobile device.