Could't set up Jitsi Meet on Debian Buster

Hello! My system is running on Debian Buster and I had trouble setting up the jitsi meet server. I tried installing jitsi meet with every server (one at a time of course), but I had no output in the browser, not even locally (just a default nginx page).

I purged apache2, nginx, jitsi and tried again and again. After some tries I got the nginx and jitsi-videobridge2 services running, but I still cannot access the jitsi-meet page.

*A thing I have to mention is I want to publish the server through a Cloudflare DNS. But first, I want to set it up locally.

What should I do to check if the jitsi is set up correctly and running? Thank you for the help!

I’ve had the same problems today. Look at the /var/log/syslog. Maybe nginx would not start as it can’t bind the port to 443. In the current setup there seems to be a conflict between the generated files between /etc/nginx/mods.available and /etc/nginx/sites-available - both reclaim port 443.


I don’t see it’s because of that. Mm…

There is something wrong with your SSL certificate, so nginx won’t start. See the [emerg] line of the syslog.

Sorry for the long time to respond. I don’t know what I did different this time, but it worked (the certificate was the problem here).

So I purged nginx and jitsi again and installed jitsi with the generated certificate from Let’s Encrypt.
I also added the domain name in the /etc/hosts to forward to 127.0.0.1 to test it locally.

But now, how do I access the server through the external cloudflare DNS?