Could not resolve org.jitsi.react:jitsi-meet-sdk:3.7.0

I am using jitsi-meet default SDK jitsi-meet to run into our react-native-jitsi-meet project. SDK build successfully But i am facing error when running Android project using that SDK.

react-native: 0.63.4
react-native-jitsi-meet: 2.2.0
Node: 17.4.0
OS: macOS BigSur

allprojects {
    repositories {
        mavenLocal()
        maven {
            // All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
            url("$rootDir/../node_modules/react-native/android")
        }
        maven {
            // Android JSC is installed from npm
            url("$rootDir/../node_modules/jsc-android/dist")
        }

         maven { url 'https://maven.google.com' }

        google()
        jcenter()

    maven {
  
              url("$rootDir/../EB")

        } 

        maven { url 'https://www.jitpack.io' }
    }
}

here

maven {
  
              url("$rootDir/../EB")

        }

is my custom SDK built from jitsi-meet SDK codebase. default github sdk is working but custom SDK shows below error.

Could not HEAD 'https://www.jitpack.io/org/jitsi/react/jitsi-meet-sdk/3.7.0/jitsi-meet-sdk-3.7.0.pom'. Received status code 401 from server: Unauthorized

I have the same question!

add this in android/build.gradle

maven { // <---- Add this block
url “jitsi-maven-repository/releases at master · jitsi/jitsi-maven-repository · GitHub
}
mentioned in repo- react-native-jitsi-meet - npm

inside node_modules/react-native-jitsi-meet/android/build.gradle
replace the implementation ('org.jitsi.react:jitsi-meet-sdk:3.7.0') {//replace the sdk version with the version you used.
in the SDK generate file you will get the jitsi meet sdk used version in the following path org/jitsi/react/jitsi-meet-sdk/5.1.0

you need to replace 3.7.0 with your SDK version for this example you need to replace it with 5.1.0