Coturn related - multiple network interfaces / multiple IP public on server

Greetings:

I’m running self hosted on actual baremetal server with multiple network interfaces:

eno1 with IP public A - built-in
eno2 (not used) - built-in
exsf0 100.71.0.2 - SFP
exsf1 100.72.0.2 - SFP

both exsf0 and exsf1 connects to a router / switch with IP public B, domain points to IP Public B,

jvb sip-communicator.properties

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=IP Public B
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=IP Public B

I was not able to disable 1st interface eno1 (i.e.: have to leave it on ), the intention is to just use IP Public B (domain name), however, there seems to be some functions still tied to the IP Public A (for example still some end-points connect to IP Public A in turn, p2p connection)

Further notes: For the installation, IP Public A is used, we are migrating (and set the domain plus using a higher bandwidth interface) to IP Public B

Has there been similar discussion on setting / choosing interface?

Much appreciated

Do TURN FQDN and Jitsi FQDN point to IP-A or IP-B?

jitsi fqdn point to IP-B
turn fqdn also points to IP-B

What are the outputs for the following commands on Jitsi server

ping -c1 <JITSI_FQDN>
ping -c1 <TURN_FQDN>
curl ifconfig.me

ping -c1 <JITSI_FQDN>

localhost 127.0.0.1

ping -c1 <TURN_FQDN>
question: is normally TURN FQDN = to JITSI FQDN?

curl ifconfig.me

IP-B

It should be different to use TCP/443 for turns too. IIUC you use tcp/5349 for turns then they may be the same

  1. in turnserver.conf

the realm is the domain name (I assume this is the Jitsi FQDN and also the Turn FQDN)
listening-port = 3478
tls-listening-port = 5349

  1. question: in /etc/hosts, should the (jitsi fqdn) refers to 127.0.0.1 or IP-B?

in the endpoint “connection information”:

Remote address: IP-A (turn) or IP-A (turn) (p2p) <---- IP-A but if I check in interface stat, the traffic Tx and Rx are on the interface connected to IP-B (100.71.0.2)
Remote port: 10000
Local address: 100.71.0.2
Local port: 53474

and I can’t disable eno1 - IP-A, if disable, it will sever the link to the remote endpoints

Can your client resolve Jitsi FQDN correctly?

Yes, pinging the jitsi FQDN will return the IP-B

Did you change FQDN after installing?

Yes, I did reinstall from old fqdn to new fqdn, change IP-A, recently upgrade to add IP-B

Can you search for the old FQDN in /etc It may be used in some files

egrep "OLD-FQDN" /etc -R

using sudo, results nothing

Would anyone be able to share some comments why disabling the eno1 - IP-A interface will cause client(s) to drop the connection (even if the outbound traffic goes through IP-B / fqdn)?

Is this related to coturn settings?